Re: [PATCH] config: fix case sensitive subsection names on writing
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jul 27, 2018, 21:37 UTC
- Message-ID
- <xmqqk1pgl5rf.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20180727205117.243770-1-sbeller@google.com>
Stefan Beller <sbeller@google.com> writes:
Show 16 quoted lines
> A use reported a submodule issue regarding strange case indentation > issues, but it could be boiled down to the following test case: > > $ git init test && cd test > $ git config foo."Bar".key test > $ git config foo."bar".key test > $ tail -n 3 .git/config > [foo "Bar"] > key = test > key = test > > Sub sections are case sensitive and we have a test for correctly reading > them. However we do not have a test for writing out config correctly with > case sensitive subsection names, which is why this went unnoticed in > 6ae996f2acf (git_config_set: make use of the config parser's event > stream, 2018-04-09)
Thanks for finding this bug and fixing it; yes it would have been even nicer if we caught it before it hit 'master', but we can only do what we can X-<.
Show 29 quoted lines
> diff --git a/config.c b/config.c
> index 3aacddfec4b..3ded92b678b 100644
> --- a/config.c
> +++ b/config.c
> @@ -2374,7 +2374,7 @@ static int store_aux_event(enum config_event_t type,
> store->is_keys_section =
> store->parsed[store->parsed_nr].is_keys_section =
> cf->var.len - 1 == store->baselen &&
> - !strncasecmp(cf->var.buf, store->key, store->baselen);
> + !strncmp(cf->var.buf, store->key, store->baselen);
> if (store->is_keys_section) {
> store->section_seen = 1;
> ALLOC_GROW(store->seen, store->seen_nr + 1,
> diff --git a/t/t1300-config.sh b/t/t1300-config.sh
> index 03c223708eb..8325d4495f4 100755
> --- a/t/t1300-config.sh
> +++ b/t/t1300-config.sh
> @@ -1218,6 +1218,24 @@ test_expect_success 'last one wins: three level vars' '
> test_cmp expect actual
> '
>
> +test_expect_success 'setting different case subsections ' '
> + test_when_finished "rm -f caseSens caseSens_actual caseSens_expect" &&
> +
> + # v.a.r and v.A.r are not the same variable, as the middle
> + # level of a three-level configuration variable name is
> + # case sensitive.
> + git config -f caseSens v."A".r VAL &&
> + git config -f caseSens v."a".r val &&It probably is easier to read to write these as "v.A.r" and "v.a.r" respectively.
Show 13 quoted lines
> + > + echo VAL >caseSens_expect && > + git config -f caseSens v."A".r >caseSens_actual && > + test_cmp caseSens_expect caseSens_actual && > + > + echo val >caseSens_expect && > + git config -f caseSens v."a".r >caseSens_actual && > + test_cmp caseSens_expect caseSens_actual > +' > + > for VAR in a .a a. a.0b a."b c". a."b c".0d > do > test_expect_success "git -c $VAR=VAL rejects invalid '$VAR'" '