Re: [PATCH] config: option transfer.ipversion to set transport protocol version for network fetches
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Sep 16, 2020, 22:50 UTC
- Message-ID
- <xmqqbli5uyj4.fsf@gitster.c.googlers.com>
- In-Reply-To
- <20200916201830.GA44969@coredump.intra.peff.net>
Jeff King <peff@peff.net> writes:
> Adding a command-line option for "all" is a good idea, but will probably > mean needing to add the "unset" sentinel value I mentioned in the other > email.
Sorry, I do not quite follow. I thought that assigning the (misnamed --- see other mail) ALL to the "family" variable would be sufficient?
enum transport_family {
TRANSPORT_FAMILY_ALL = 0,
TRANSPORT_FAMILY_IPV4,
TRANSPORT_FAMILY_IPV6
};