From: Junio C Hamano Date: Wed, 16 Sep 2020 22:50:23 GMT Subject: Re: [PATCH] config: option transfer.ipversion to set transport protocol version for network fetches Message-ID: In-Reply-To: <20200916201830.GA44969@coredump.intra.peff.net> Jeff King writes: > Adding a command-line option for "all" is a good idea, but will probably > mean needing to add the "unset" sentinel value I mentioned in the other > email. Sorry, I do not quite follow. I thought that assigning the (misnamed --- see other mail) ALL to the "family" variable would be sufficient? enum transport_family { TRANSPORT_FAMILY_ALL = 0, TRANSPORT_FAMILY_IPV4, TRANSPORT_FAMILY_IPV6 };