Re: [PATCH] config: option transfer.ipversion to set transport protocol version for network fetches
- From
Jeff King <peff@peff.net>
- Date
- Sep 16, 2020, 20:18 UTC
- Message-ID
- <20200916201830.GA44969@coredump.intra.peff.net>
- In-Reply-To
- <xmqqtuvxwkbz.fsf@gitster.c.googlers.com>
On Wed, Sep 16, 2020 at 01:14:08PM -0700, Junio C Hamano wrote:
Show 10 quoted lines
> Alex Riesen <alexander.riesen@cetitec.com> writes: > > > Affecting the transfers caused by git-fetch, the > > option allows to control network operations similar > > to --ipv4 and --ipv6 options. > > ... > > Something like this? > > Good start. > [...]
A lot of your comments apply to the "something like this" suggestion I just posted, so I wanted to save a round-trip and say: yes, I agree with all of your suggestions here.
Adding a command-line option for "all" is a good idea, but will probably mean needing to add the "unset" sentinel value I mentioned in the other email.
Show 10 quoted lines
> Would we regret to choose 'ipversion' as the variable name, by the > way? On the command line side, --transfer-protocol-family=ipv4 > makes it clear that we leave room to support protocols outside the > Internet protocol family, and existing --ipv4 is grandfathered in > by making it a synonym to --transfer-protocol-family=ipv4. Calling > the variable "transfer.ipversion" and still allowing future protocols > outside the Internet protocol family is rather awkward. > > Calling "transfer.protocolFamily" would not have such a problem, > though.
I agree that's a better name. I'm still on the fence about "transfer" versus "core".
-Peff