Re: [PATCH 0/3] Re: [PATCH] check-ref-format: require a repository for --branch
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Oct 17, 2017, 08:21 UTC
- Message-ID
- <xmqqa80qnq1f.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <20171017071758.ltzustqxcbp3yet7@aiede.mtv.corp.google.com>
Jonathan Nieder <jrnieder@gmail.com> writes:
Show 13 quoted lines
> Junio C Hamano wrote: >> Jonathan Nieder <jrnieder@gmail.com> writes: > >>> Handles the nongit case in strbuf_check_branch_ref instead of >>> introducing a new check_branch_ref_format helper. >> >> I view that as a regression, actually. Don't we want a function >> that does not require a strbuf when asking a simple question: "I >> have a string, and I want to see if that is a valid name"? > > *shrug* I found the change easier to read, and it also sidesteps the > which-header question. It also ensures that other > strbuf_check_branch_ref callers are safe without having to audit them.
Please ignore the above, which was merely an impression _without_ and before having received any patch to comment on ;-)
Quite frankly, this is a Meh topic that won't have to hit even 'next' before the final. The color.ui=always thing has a lot more urgency, and this was merely what I did while waiting for others to react to that topic.