Re: [PATCH 0/3] Re: [PATCH] check-ref-format: require a repository for --branch
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Oct 17, 2017, 07:17 UTC
- Message-ID
- <20171017071758.ltzustqxcbp3yet7@aiede.mtv.corp.google.com>
- In-Reply-To
- <xmqqefq2nt7w.fsf@gitster.mtv.corp.google.com>
Junio C Hamano wrote:
> Jonathan Nieder <jrnieder@gmail.com> writes:
Show 6 quoted lines
>> Handles the nongit case in strbuf_check_branch_ref instead of >> introducing a new check_branch_ref_format helper. > > I view that as a regression, actually. Don't we want a function > that does not require a strbuf when asking a simple question: "I > have a string, and I want to see if that is a valid name"?
*shrug* I found the change easier to read, and it also sidesteps the which-header question. It also ensures that other strbuf_check_branch_ref callers are safe without having to audit them.
But feel free to tweak that back if you like, or I can tomorrow.
Jonathan