Re: [GSoC][PATCH v4 1/2] sequencer: make two functions and an enum from sequencer.c public
- From
Alban Gruin <alban.gruin@gmail.com>
- Date
- Jun 27, 2018, 14:54 UTC
- Message-ID
- <e2d8310a-0bbc-b786-97c1-e32c2090aca9@gmail.com>
- In-Reply-To
- <nycvar.QRO.7.76.6.1806262337360.21419@tvgsbejvaqbjf.bet>
Hi Johannes,
Le 26/06/2018 à 23:41, Johannes Schindelin a écrit :
Show 37 quoted lines
> Hi Alban,
>
> On Tue, 26 Jun 2018, Alban Gruin wrote:
>
>> diff --git a/sequencer.h b/sequencer.h
>> index c5787c6b5..08397b0d1 100644
>> --- a/sequencer.h
>> +++ b/sequencer.h
>> @@ -3,6 +3,7 @@
>>
>> const char *git_path_commit_editmsg(void);
>> const char *git_path_seq_dir(void);
>> +const char *rebase_path_todo(void);
>>
>> #define APPEND_SIGNOFF_DEDUP (1u << 0)
>>
>> @@ -57,6 +58,10 @@ struct replay_opts {
>> };
>> #define REPLAY_OPTS_INIT { .action = -1, .current_fixups = STRBUF_INIT }
>>
>> +enum check_level {
>> + CHECK_IGNORE = 0, CHECK_WARN, CHECK_ERROR
>> +};
>> +
>
> While this is contained within scopes that include `sequencer.h`, it *is*
> public now, so I am slightly uneasy about keeping this enum so generic.
> Maybe we want to use
>
> enum missing_commit_check_level {
> MISSING_COMMIT_CHECK_IGNORE = 0,
> MISSING_COMMIT_CHECK_WARN,
> MISSING_COMMIT_CHECK_ERROR
> };
>
> instead?
> You’re right, this would be better.
Cheers, Alban