[PATCH v2 00/20] Separate `ref_cache` into a separate module
- From
Michael Haggerty <mhagger@alum.mit.edu>
- Date
- Mar 31, 2017, 14:10 UTC
- Message-ID
- <cover.1490966385.git.mhagger@alum.mit.edu>
This is v2 of this patch series. Thanks to Peff, Junio, Stefan and Ævar for their comments about v1 [1].
This version literally only contains a few commit message changes and one minor comment changes relative to v1. The code is identical. I wasn't sure whether it is even worth sending this patch series to the ML again; Junio, if you'd prefer I just send a link to a published branch in such cases, please let me know.
* I picked up the "area:" prefixes that Junio added to a couple of commit subject lines.
* I clarified the justification for keeping a pointer to the `ref_store` in `ref_dir`.
* I added a long blurb about the removal of an internal consistency check in the commit message for
[18/20] commit_packed_refs(): use reference iteration
* I changed "loose refs cache" to "loose ref cache" in a comment in
[19/20] files_pack_refs(): use reference iteration
This patch series is also available from my GitHub fork [2] as branch "separate-ref-cache". These patches depend on Duy's nd/files-backend-git-dir branch.
[1] http://public-inbox.org/git/cover.1490026594.git.mhagger@alum.mit.edu/ [2] https://github.com/mhagger/git
Michael Haggerty (20): get_ref_dir(): don't call read_loose_refs() for "refs/bisect" refs_read_raw_ref(): new function refs_ref_iterator_begin(): new function refs_verify_refname_available(): implement once for all backends refs_verify_refname_available(): use function in more places ref-cache: rename `add_ref()` to `add_ref_entry()` ref-cache: rename `find_ref()` to `find_ref_entry()` ref-cache: rename `remove_entry()` to `remove_entry_from_dir()` refs: split `ref_cache` code into separate files ref-cache: introduce a new type, ref_cache refs: record the ref_store in ref_cache, not ref_dir ref-cache: use a callback function to fill the cache refs: handle "refs/bisect/" in `loose_fill_ref_dir()` do_for_each_entry_in_dir(): eliminate `offset` argument get_loose_ref_dir(): function renamed from get_loose_refs() get_loose_ref_cache(): new function cache_ref_iterator_begin(): make function smarter commit_packed_refs(): use reference iteration files_pack_refs(): use reference iteration do_for_each_entry_in_dir(): delete function
Makefile | 1 + refs.c | 111 ++++- refs.h | 2 +- refs/files-backend.c | 1229 +++++++------------------------------------------- refs/ref-cache.c | 523 +++++++++++++++++++++ refs/ref-cache.h | 267 +++++++++++ refs/refs-internal.h | 22 +- 7 files changed, 1066 insertions(+), 1089 deletions(-) create mode 100644 refs/ref-cache.c create mode 100644 refs/ref-cache.h
-- 2.11.0