git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 01/20] get_ref_dir(): don't call read_loose_refs() for "refs/bisect"

From
Stefan Beller <sbeller@google.com>
Date
Mar 31, 2017, 17:18 UTC
Message-ID
<CAGZ79kZ9uGjhN5n8YAdUh2xqDMxTmmfsa7rCEWMk-Bsp5uxncg@mail.gmail.com>
In-Reply-To
<53e0eed5e13a04f502dcaeda83b2cbb3035f1396.1490966385.git.mhagger@alum.mit.edu>
On Fri, Mar 31, 2017 at 7:10 AM, Michael Haggerty <mhagger@alum.mit.edu> wrote:
Show 26 quoted lines
> Since references under "refs/bisect/" are per-worktree, they have to
> be sought in the worktree rather than in the main repository. But
> since loose references are found by traversing directories, the
> reference iterator won't even get the idea to look for a
> "refs/bisect/" directory in the worktree if there is not a directory
> with that name in the main repository. Thus `get_ref_dir()` manually
> inserts a dir_entry for "refs/bisect/" whenever it reads the entry for
> "refs/".
>
> The current code then immediately calls `read_loose_refs()` on that
> directory. But since the dir_entry is created with its `incomplete`
> flag set, any traversal that gets to this point will read the
> directory automatically. So there is no need to call
> `read_loose_refs()` explicitly; the lazy mechanism suffices.
>
> And in fact, the attempt to `read_loose_refs()` was broken anyway.
> That function needs its `dirname` argument to have a trailing `/`
> character, but the invocation here was passing it "refs/bisect"
> without a trailing slash. So `read_loose_refs()` would read
> `$GIT_DIR/refs/bisect" correctly, but if it found an entry "foo" in
> that directory, it would try to read "$GIT_DIR/refs/bisectfoo".
> Normally it wouldn't find anything at that path, but the failure was
> canceled out because `get_ref_dir()` *also* forgot to reset the
> `REF_INCOMPLETE` bit on the dir_entry. So the read was attempted again
> when it was accessed, via the lazy mechanism, and this time the read
> was done correctly.

With all this retry logic going on, it is hard to add a test demonstrating this is correct now. The description makes sense though.

Thanks, Stefan

Previous: Michael HaggertyNext: Michael Haggerty
Message 3 of 42 in “Separate `ref_cache` into a separate module”
  1. 00/20 Separate `ref_cache` into a separate moduleMichael Haggerty, Mar 31, 2017
  2. 01/20 get_ref_dir(): don't call read_loose_refs() for "refs/bisect"Michael Haggerty, Mar 31, 2017
  3. Stefan BellerMar 31, 2017
  4. 02/20 refs_read_raw_ref(): new functionMichael Haggerty, Mar 31, 2017
  5. 04/20 refs_verify_refname_available(): implement once for all backendsMichael Haggerty, Mar 31, 2017
  6. Duy NguyenApr 7, 2017
  7. Michael HaggertyApr 16, 2017
  8. 06/20 ref-cache: rename `add_ref()` to `add_ref_entry()`Michael Haggerty, Mar 31, 2017
  9. 07/20 ref-cache: rename `find_ref()` to `find_ref_entry()`Michael Haggerty, Mar 31, 2017
  10. 08/20 ref-cache: rename `remove_entry()` to `remove_entry_from_dir()`Michael Haggerty, Mar 31, 2017
  11. 03/20 refs_ref_iterator_begin(): new functionMichael Haggerty, Mar 31, 2017
  12. Duy NguyenApr 7, 2017
  13. Michael HaggertyApr 16, 2017
  14. 05/20 refs_verify_refname_available(): use function in more placesMichael Haggerty, Mar 31, 2017
  15. 12/20 ref-cache: use a callback function to fill the cacheMichael Haggerty, Mar 31, 2017
  16. 09/20 refs: split `ref_cache` code into separate filesMichael Haggerty, Mar 31, 2017
  17. 15/20 get_loose_ref_dir(): function renamed from get_loose_refs()Michael Haggerty, Mar 31, 2017
  18. 16/20 get_loose_ref_cache(): new functionMichael Haggerty, Mar 31, 2017
  19. 19/20 files_pack_refs(): use reference iterationMichael Haggerty, Mar 31, 2017
  20. Duy NguyenApr 7, 2017
  21. Michael HaggertyApr 16, 2017
  22. 17/20 cache_ref_iterator_begin(): make function smarterMichael Haggerty, Mar 31, 2017
  23. 18/20 commit_packed_refs(): use reference iterationMichael Haggerty, Mar 31, 2017
  24. 13/20 refs: handle "refs/bisect/" in `loose_fill_ref_dir()`Michael Haggerty, Mar 31, 2017
  25. 20/20 do_for_each_entry_in_dir(): delete functionMichael Haggerty, Mar 31, 2017
  26. 10/20 ref-cache: introduce a new type, ref_cacheMichael Haggerty, Mar 31, 2017
  27. Duy NguyenApr 7, 2017
  28. Michael HaggertyApr 16, 2017
  29. 14/20 do_for_each_entry_in_dir(): eliminate `offset` argumentMichael Haggerty, Mar 31, 2017
  30. 11/20 refs: record the ref_store in ref_cache, not ref_dirMichael Haggerty, Mar 31, 2017
  31. Duy NguyenApr 7, 2017
  32. Michael HaggertyApr 16, 2017
  33. Junio C HamanoMar 31, 2017
  34. Michael HaggertyApr 1, 2017
  35. Duy NguyenApr 5, 2017
  36. Duy NguyenApr 7, 2017
  37. Michael HaggertyApr 16, 2017
  38. Ramsay JonesApr 1, 2017
  39. Junio C HamanoApr 2, 2017
  40. Ramsay JonesApr 2, 2017
  41. Junio C HamanoApr 2, 2017
  42. Jeff KingApr 1, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.