git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v2 07/20] ref-cache: rename `find_ref()` to `find_ref_entry()`

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Mar 31, 2017, 14:11 UTC
Message-ID
<279df1fe591349db97aa4a5dd30ec57a0dba3c2e.1490966385.git.mhagger@alum.mit.edu>
In-Reply-To
<cover.1490966385.git.mhagger@alum.mit.edu>

This function's visibility is about to be increased, so give it a more distinctive name.

Signed-off-by: Michael Haggerty <mhagger@alum.mit.edu>
---
 refs/files-backend.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/refs/files-backend.c b/refs/files-backend.c
index 4d579cbdac..6768c8c86b 100644
--- a/refs/files-backend.c
+++ b/refs/files-backend.c
@@ -385,7 +385,7 @@ static struct ref_dir *find_containing_dir(struct ref_dir *dir,
  * and recursing into subdirectories as necessary.  If the name is not
  * found or it corresponds to a directory entry, return NULL.
  */
-static struct ref_entry *find_ref(struct ref_dir *dir, const char *refname)
+static struct ref_entry *find_ref_entry(struct ref_dir *dir, const char *refname)
 {
 	int entry_index;
 	struct ref_entry *entry;
@@ -1227,7 +1227,7 @@ static struct ref_dir *get_loose_refs(struct files_ref_store *refs)
 static struct ref_entry *get_packed_ref(struct files_ref_store *refs,
 					const char *refname)
 {
-	return find_ref(get_packed_refs(refs), refname);
+	return find_ref_entry(get_packed_refs(refs), refname);
 }
 
 /*
@@ -2171,7 +2171,7 @@ static int pack_if_possible_fn(struct ref_entry *entry, void *cb_data)
 	if (peel_status != PEEL_PEELED && peel_status != PEEL_NON_TAG)
 		die("internal error peeling reference %s (%s)",
 		    entry->name, oid_to_hex(&entry->u.value.oid));
-	packed_entry = find_ref(cb->packed_refs, entry->name);
+	packed_entry = find_ref_entry(cb->packed_refs, entry->name);
 	if (packed_entry) {
 		/* Overwrite existing packed entry with info from loose entry */
 		packed_entry->flag = REF_ISPACKED | REF_KNOWS_PEELED;
-- 
2.11.0
Previous: Michael HaggertyNext: Michael Haggerty
Message 9 of 42 in “Separate `ref_cache` into a separate module”
  1. 00/20 Separate `ref_cache` into a separate moduleMichael Haggerty, Mar 31, 2017
  2. 01/20 get_ref_dir(): don't call read_loose_refs() for "refs/bisect"Michael Haggerty, Mar 31, 2017
  3. Stefan BellerMar 31, 2017
  4. 02/20 refs_read_raw_ref(): new functionMichael Haggerty, Mar 31, 2017
  5. 04/20 refs_verify_refname_available(): implement once for all backendsMichael Haggerty, Mar 31, 2017
  6. Duy NguyenApr 7, 2017
  7. Michael HaggertyApr 16, 2017
  8. 06/20 ref-cache: rename `add_ref()` to `add_ref_entry()`Michael Haggerty, Mar 31, 2017
  9. 07/20 ref-cache: rename `find_ref()` to `find_ref_entry()`Michael Haggerty, Mar 31, 2017
  10. 08/20 ref-cache: rename `remove_entry()` to `remove_entry_from_dir()`Michael Haggerty, Mar 31, 2017
  11. 03/20 refs_ref_iterator_begin(): new functionMichael Haggerty, Mar 31, 2017
  12. Duy NguyenApr 7, 2017
  13. Michael HaggertyApr 16, 2017
  14. 05/20 refs_verify_refname_available(): use function in more placesMichael Haggerty, Mar 31, 2017
  15. 12/20 ref-cache: use a callback function to fill the cacheMichael Haggerty, Mar 31, 2017
  16. 09/20 refs: split `ref_cache` code into separate filesMichael Haggerty, Mar 31, 2017
  17. 15/20 get_loose_ref_dir(): function renamed from get_loose_refs()Michael Haggerty, Mar 31, 2017
  18. 16/20 get_loose_ref_cache(): new functionMichael Haggerty, Mar 31, 2017
  19. 19/20 files_pack_refs(): use reference iterationMichael Haggerty, Mar 31, 2017
  20. Duy NguyenApr 7, 2017
  21. Michael HaggertyApr 16, 2017
  22. 17/20 cache_ref_iterator_begin(): make function smarterMichael Haggerty, Mar 31, 2017
  23. 18/20 commit_packed_refs(): use reference iterationMichael Haggerty, Mar 31, 2017
  24. 13/20 refs: handle "refs/bisect/" in `loose_fill_ref_dir()`Michael Haggerty, Mar 31, 2017
  25. 20/20 do_for_each_entry_in_dir(): delete functionMichael Haggerty, Mar 31, 2017
  26. 10/20 ref-cache: introduce a new type, ref_cacheMichael Haggerty, Mar 31, 2017
  27. Duy NguyenApr 7, 2017
  28. Michael HaggertyApr 16, 2017
  29. 14/20 do_for_each_entry_in_dir(): eliminate `offset` argumentMichael Haggerty, Mar 31, 2017
  30. 11/20 refs: record the ref_store in ref_cache, not ref_dirMichael Haggerty, Mar 31, 2017
  31. Duy NguyenApr 7, 2017
  32. Michael HaggertyApr 16, 2017
  33. Junio C HamanoMar 31, 2017
  34. Michael HaggertyApr 1, 2017
  35. Duy NguyenApr 5, 2017
  36. Duy NguyenApr 7, 2017
  37. Michael HaggertyApr 16, 2017
  38. Ramsay JonesApr 1, 2017
  39. Junio C HamanoApr 2, 2017
  40. Ramsay JonesApr 2, 2017
  41. Junio C HamanoApr 2, 2017
  42. Jeff KingApr 1, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.