git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 00/20] Separate `ref_cache` into a separate module

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Apr 1, 2017, 05:16 UTC
Message-ID
<13eaacf0-5923-ad33-79ed-2cec47660904@alum.mit.edu>
In-Reply-To
<xmqq1std1lmb.fsf@gitster.mtv.corp.google.com>
On 03/31/2017 06:01 PM, Junio C Hamano wrote:
Show 22 quoted lines
> Michael Haggerty <mhagger@alum.mit.edu> writes:
> 
>> This version literally only contains a few commit message changes and
>> one minor comment changes relative to v1. The code is identical. I
>> wasn't sure whether it is even worth sending this patch series to the
>> ML again; Junio, if you'd prefer I just send a link to a published
>> branch in such cases, please let me know.
> 
> The review on the list is not about letting me pick it up, but is
> about giving reviewing contributors a chance to comment.  I think
> for a series this important ;-) it is good that you are giving it
> multiple exposures so that people who were offline the last time can
> have a chance to look at it, even if the update is minimum.
> 
>> This patch series is also available from my GitHub fork [2] as branch
>> "separate-ref-cache". These patches depend on Duy's
>> nd/files-backend-git-dir branch.
> 
> I am getting the impression that the files-backend thing as well as
> this topic are ready for 'next'.  Please stop me if I missed something
> in these topics (especially the other one) that needs updating
> before that happens.

I don't know of any remaining problems with these two patch series (aside from a couple of cosmetic problems that I just pointed out about v7 of nd/files-backend-git-dir). I'm pretty confident about both of them.

Duy, have you looked over my patch series? Since you've been working in the area, your feedback would be very welcome, if you have the time for it.

Michael
Previous: Junio C HamanoNext: Duy Nguyen
Message 34 of 42 in “Separate `ref_cache` into a separate module”
  1. 00/20 Separate `ref_cache` into a separate moduleMichael Haggerty, Mar 31, 2017
  2. 01/20 get_ref_dir(): don't call read_loose_refs() for "refs/bisect"Michael Haggerty, Mar 31, 2017
  3. Stefan BellerMar 31, 2017
  4. 02/20 refs_read_raw_ref(): new functionMichael Haggerty, Mar 31, 2017
  5. 04/20 refs_verify_refname_available(): implement once for all backendsMichael Haggerty, Mar 31, 2017
  6. Duy NguyenApr 7, 2017
  7. Michael HaggertyApr 16, 2017
  8. 06/20 ref-cache: rename `add_ref()` to `add_ref_entry()`Michael Haggerty, Mar 31, 2017
  9. 07/20 ref-cache: rename `find_ref()` to `find_ref_entry()`Michael Haggerty, Mar 31, 2017
  10. 08/20 ref-cache: rename `remove_entry()` to `remove_entry_from_dir()`Michael Haggerty, Mar 31, 2017
  11. 03/20 refs_ref_iterator_begin(): new functionMichael Haggerty, Mar 31, 2017
  12. Duy NguyenApr 7, 2017
  13. Michael HaggertyApr 16, 2017
  14. 05/20 refs_verify_refname_available(): use function in more placesMichael Haggerty, Mar 31, 2017
  15. 12/20 ref-cache: use a callback function to fill the cacheMichael Haggerty, Mar 31, 2017
  16. 09/20 refs: split `ref_cache` code into separate filesMichael Haggerty, Mar 31, 2017
  17. 15/20 get_loose_ref_dir(): function renamed from get_loose_refs()Michael Haggerty, Mar 31, 2017
  18. 16/20 get_loose_ref_cache(): new functionMichael Haggerty, Mar 31, 2017
  19. 19/20 files_pack_refs(): use reference iterationMichael Haggerty, Mar 31, 2017
  20. Duy NguyenApr 7, 2017
  21. Michael HaggertyApr 16, 2017
  22. 17/20 cache_ref_iterator_begin(): make function smarterMichael Haggerty, Mar 31, 2017
  23. 18/20 commit_packed_refs(): use reference iterationMichael Haggerty, Mar 31, 2017
  24. 13/20 refs: handle "refs/bisect/" in `loose_fill_ref_dir()`Michael Haggerty, Mar 31, 2017
  25. 20/20 do_for_each_entry_in_dir(): delete functionMichael Haggerty, Mar 31, 2017
  26. 10/20 ref-cache: introduce a new type, ref_cacheMichael Haggerty, Mar 31, 2017
  27. Duy NguyenApr 7, 2017
  28. Michael HaggertyApr 16, 2017
  29. 14/20 do_for_each_entry_in_dir(): eliminate `offset` argumentMichael Haggerty, Mar 31, 2017
  30. 11/20 refs: record the ref_store in ref_cache, not ref_dirMichael Haggerty, Mar 31, 2017
  31. Duy NguyenApr 7, 2017
  32. Michael HaggertyApr 16, 2017
  33. Junio C HamanoMar 31, 2017
  34. Michael HaggertyApr 1, 2017
  35. Duy NguyenApr 5, 2017
  36. Duy NguyenApr 7, 2017
  37. Michael HaggertyApr 16, 2017
  38. Ramsay JonesApr 1, 2017
  39. Junio C HamanoApr 2, 2017
  40. Ramsay JonesApr 2, 2017
  41. Junio C HamanoApr 2, 2017
  42. Jeff KingApr 1, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.