Re: [PATCH v2 19/20] files_pack_refs(): use reference iteration
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- Apr 7, 2017, 11:51 UTC
- Message-ID
- <CACsJy8DAFUQnjkLnaXD0aM_97_E_7F_=fMeJb2Azigt2Pv0gTw@mail.gmail.com>
- In-Reply-To
- <1d131a33fd155f14908ee1d41e98be8a1309c6b9.1490966385.git.mhagger@alum.mit.edu>
On Fri, Mar 31, 2017 at 9:11 PM, Michael Haggerty <mhagger@alum.mit.edu> wrote:
> Use reference iteration rather than do_for_each_entry_in_dir() in the > definition of files_pack_refs().
A "why" is missing here. My guess is readability/maintainability because it's easier to follow the code with iterator design, than the callback one? No maintaining data in struct pack_refs_cb_data is also very nice.
-- Duy