Re: [doc] User Manual Suggestion
- From
Michael Witten <mfwitten@gmail.com>
- Date
- Apr 25, 2009, 00:19 UTC
- Message-ID
- <b4087cc50904241719w64bc6074xe5b8d341ef9f51ed@mail.gmail.com>
- In-Reply-To
- <20090424233509.GA15341@coredump.intra.peff.net>
On Fri, Apr 24, 2009 at 18:35, Jeff King <peff@peff.net> wrote:
Show 16 quoted lines
> On Fri, Apr 24, 2009 at 06:31:26PM -0500, Michael Witten wrote: > >> On Fri, Apr 24, 2009 at 18:14, Jeff King <peff@peff.net> wrote: >> > Junio suggested "object name" in another thread, which I think is nicely >> > descriptive. >> >> The reason I don't like "object name" is that "name" has connotations >> that don't go well with the idea of referencing. Isn't "address" (or >> "location") better in this sense? > > I'm not sure I agree, but if you are concerned with "name", then I think > something like "object id" or "object identifier" would probably be > better. "address" and "location" imply to me that they are part of a > contiguous set. And while technically they may be considered addresses > of a sparse 2^160 array, I'm not sure that explanation is really helping > new users understand what is going on.
You make an interesting point about implied contiguousness, but I don't think any git operation is in danger of evoking that thought. I mainly like the idea of "address" and "location", because they go extremely well with "pointer", "handle" and the idea of a "git store (memory)". Most importantly, this is an analogy that has been around a long time.