Re: [doc] User Manual Suggestion
- From
Jeff King <peff@peff.net>
- Date
- Apr 24, 2009, 23:35 UTC
- Message-ID
- <20090424233509.GA15341@coredump.intra.peff.net>
- In-Reply-To
- <b4087cc50904241631t8913c47ke3b2027b466ee1e9@mail.gmail.com>
On Fri, Apr 24, 2009 at 06:31:26PM -0500, Michael Witten wrote:
Show 7 quoted lines
> On Fri, Apr 24, 2009 at 18:14, Jeff King <peff@peff.net> wrote: > > Junio suggested "object name" in another thread, which I think is nicely > > descriptive. > > The reason I don't like "object name" is that "name" has connotations > that don't go well with the idea of referencing. Isn't "address" (or > "location") better in this sense?
I'm not sure I agree, but if you are concerned with "name", then I think something like "object id" or "object identifier" would probably be better. "address" and "location" imply to me that they are part of a contiguous set. And while technically they may be considered addresses of a sparse 2^160 array, I'm not sure that explanation is really helping new users understand what is going on.
What the user really cares about is that it is persistent and unambiguous.
-Peff