Re: [PATCH/RFC 0/3] Per-repository end-of-line normalization
- From
Nicolas Pitre <nico@fluxnic.net>
- Date
- May 7, 2010, 19:31 UTC
- Message-ID
- <alpine.LFD.2.00.1005071529050.14468@xanadu.home>
- In-Reply-To
- <alpine.LFD.2.00.1005071147460.901@i5.linux-foundation.org>
On Fri, 7 May 2010, Linus Torvalds wrote:
Show 14 quoted lines
> Btw, another option might be to start searching ".gitconfig", but only > allow a certain "safe subset" of config options in that. Things that can > really be about the project itself, and not per-user or per-repository. > > And parse it before ~/.gitconfig and .git/config, so that people can > always override it. > > I dunno. Looking at the config options, there really aren't a lot of them > that make sense on a project scale. There's a few, though. Things like > > core.autocrlf > i18n.commitEnconfig > > and possibly others..
Given that only a subset of gitconfig could make sense to have distributed, I think the file should be named .gitparams to make the distinction clear.
Nicolas