Show 20 quoted lines
> On Mon, Mar 30, 2009 at 11:00:03AM +0200, Santi Béjar wrote:
>
>> >> This configuration variable says what push should do
>> >> when no refspec is given and none are configured, so the word "default"
>> >> should be in there at least. Maybe "defaultref" would have been better?
>>
>> I don't see the point of the word default, a lot of configuration is
>> to set the default value. Git has branch.name.remote, not
>> branch.name.defaultremote, or user.email, not user.defaultemail,...
>
> The usual case is two layers of options: command line and config
> options. Thus "git push <remote>" overrides "branch.*.remote".
>
> But in this case there are actually _three_ layers: command line,
> branch.*.push, and now push.default. I think a name like "push.mode"
> doesn't make clear the fact that it will never be looked at if you have
> "branch.*.push" set up.
>
> I think you have a point that "default" is vague, but "defaultMode"
> would be better than simply "mode".