git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 4/4] Rename push.default to push.style

From
SBSanti Béjar <santi@agolina.net>
Date
Mar 30, 2009, 09:00 UTC
Message-ID
<adf1fd3d0903300200v65393b1bif0050392aa44652e@mail.gmail.com>
In-Reply-To
<alpine.DEB.1.00.0903301021540.7534@intel-tinevez-2-302>
2009/3/30 Johannes Schindelin <Johannes.Schindelin@gmx.de>:
Show 18 quoted lines
> Hi,
>
> On Mon, 30 Mar 2009, Finn Arne Gangstad wrote:
>
>> On Sun, Mar 29, 2009 at 12:10:04AM +0100, Santi Béjar wrote:
>> > push.default was too generic, and also didn't specify if it was about
>> > remote, refspec, branches, behaviour...
>> > [...]
>> >     "You can specify what action you want to take in this case, and",
>> > -   "avoid seeing this message again, by configuring 'push.default' to:",
>> > +   "avoid seeing this message again, by configuring 'push.style' to:",
>> >     "  'nothing'  : Do not push anything",
>> >     "  'matching' : Push all matching branches (default)",
>> >     "  'tracking' : Push the current branch to whatever it is tracking",
>> > [...]
>>
>> I don't think "push.style" is an improvement. "style" sounds like it
>> affects all pushes.
Not for me. I says the style of the push. But maybe push.mode could be better.
>> This configuration variable says what push should do
>> when no refspec is given and none are configured, so the word "default"
>> should be in there at least. Maybe "defaultref" would have been better?

I don't see the point of the word default, a lot of configuration is to set the default value. Git has branch.name.remote, not branch.name.defaultremote, or user.email, not user.defaultemail,...

Show 7 quoted lines
>
> I'd prefer "push.defaultMode", but...
>
>> Some people may have started setting push.default already, so changing
>> the name may cause additional grief.
>
> ... indeed, it is too late now.  The milk has boiled already.

I have it configured, but I think we can fix these type of things while they are in 'next'.

Santi
Previous: Johannes SchindelinNext: Santi Béjar
Message 10 of 13 in “push.default and branch.<name>.{remote,merge} changes”
  1. 0/4 push.default and branch.<name>.{remote,merge} changesSanti Béjar, Mar 28, 2009
  2. 1/4 Documentation: enhance branch.<name>.{remote,merge}Santi Béjar, Mar 28, 2009
  3. Jay SoffianMar 29, 2009
  4. Santi BéjarMar 29, 2009
  5. 2/4 Documentation: push.default applies to all remotesSanti Béjar, Mar 28, 2009
  6. 3/4 Documentation: branch.*.merge can also afect 'git-push'Santi Béjar, Mar 28, 2009
  7. 4/4 Rename push.default to push.styleSanti Béjar, Mar 28, 2009
  8. Finn Arne GangstadMar 30, 2009
  9. Johannes SchindelinMar 30, 2009
  10. Santi BéjarMar 30, 2009
  11. Santi BéjarMar 30, 2009
  12. Jeff KingMar 30, 2009
  13. Santi BéjarMar 30, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.