Re: [PATCH 2/3] ident: rename commit_rewrite_person() to rewrite_ident_line()
- From
- Phillip Wood <phillip.wood123@gmail.com>
- Date
- Jun 30, 2022, 15:33 UTC
- Message-ID
- <ad7fff11-5ab2-d314-5e12-bdf61b854aa6@gmail.com>
- In-Reply-To
- <20220630142444.651948-3-siddharthasthana31@gmail.com>
Hi Siddharth
Welcome to the list!
On 30/06/2022 15:24, Siddharth Asthana wrote:
Show 9 quoted lines
> We will be using commit_rewrite_person() in git-cat-file to rewrite > ident line in commit/tag object buffers. > > Following are the reason for renaming commit_rewrite_person(): > - the function can be used not only on a commit buffer, but also on a > tag object buffer, so having "commit" in its name is misleading. > - the function works on the ident line in the commit/tag object buffers, > just like "split_ident_line()". Since these functions are related they > should have similar terms for uniformity.
I'm afraid I'm not sure about this change as the interface for split_ident_line() and commit_rewrite_person() are not uniform. split_ident_line() takes a pointer to the beginning of the name in an ident line and a length. commit_rewrite_person() takes the whole commit buffer and searches for the ident line based on the argument "what". I agree that having commit in the name of the function is confusing when it can be used for a tag, but having line in the name when it takes a whole buffer is also confusing. Maybe buffer_rewrite_person() or something like that would be clearer?
Best Wishes
Phillip
Show 50 quoted lines
> Signed-off-by: Siddharth Asthana <siddharthasthana31@gmail.com>
> Mentored-by: Christian Couder <christian.couder@gmail.com>
> Mentored-by: John Cai <johncai86@gmail.com>
> ---
> cache.h | 2 +-
> ident.c | 2 +-
> revision.c | 4 ++--
> 3 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/cache.h b/cache.h
> index 442bfe5f6a..c8a98d8a80 100644
> --- a/cache.h
> +++ b/cache.h
> @@ -1694,7 +1694,7 @@ int split_ident_line(struct ident_split *, const char *, int);
> * name and email using mailmap mechanism. Signals a success with
> * 1 and failure with a 0.
> */
> -int commit_rewrite_person(struct strbuf *buf, const char *what, struct string_list *mailmap);
> +int rewrite_ident_line(struct strbuf *buf, const char *what, struct string_list *mailmap);
>
> /*
> * Compare split idents for equality or strict ordering. Note that we
> diff --git a/ident.c b/ident.c
> index 8c890bd474..d15f579fd5 100644
> --- a/ident.c
> +++ b/ident.c
> @@ -347,7 +347,7 @@ int split_ident_line(struct ident_split *split, const char *line, int len)
> return 0;
> }
>
> -int commit_rewrite_person(struct strbuf *buf, const char *what, struct string_list *mailmap)
> +int rewrite_ident_line(struct strbuf *buf, const char *what, struct string_list *mailmap)
> {
> char *person, *endp;
> size_t len, namelen, maillen;
> diff --git a/revision.c b/revision.c
> index da49e73cd6..0c8243a8e0 100644
> --- a/revision.c
> +++ b/revision.c
> @@ -3790,8 +3790,8 @@ static int commit_match(struct commit *commit, struct rev_info *opt)
> if (!buf.len)
> strbuf_addstr(&buf, message);
>
> - commit_rewrite_person(&buf, "\nauthor ", opt->mailmap);
> - commit_rewrite_person(&buf, "\ncommitter ", opt->mailmap);
> + rewrite_ident_line(&buf, "\nauthor ", opt->mailmap);
> + rewrite_ident_line(&buf, "\ncommitter ", opt->mailmap);
> }
>
> /* Append "fake" message parts as needed */