Re: [PATCH v6 0/4] Add support for mailmap in cat-file
- From
Christian Couder <christian.couder@gmail.com>
- Date
- Jul 28, 2022, 19:07 UTC
- Message-ID
- <CAP8UFD0U8hQ+gyN1=7M4oYEhX6=z_1LS4JaLjqdPG52BELRqtg@mail.gmail.com>
- In-Reply-To
- <xmqqpmht3tq1.fsf@gitster.g>
On Mon, Jul 25, 2022 at 8:58 PM Junio C Hamano <gitster@pobox.com> wrote:
Show 29 quoted lines
> Siddharth Asthana <siddharthasthana31@gmail.com> writes: > > > Changes in v6: > > - The function rewrite_ident_line() returns the difference between the > > new and the old length of the ident line. We were not using this > > information and instead parsing the buffer again to look for the line > > ending. This patch set starts using that information to update the > > buf_offset value in commit_rewrite_person(). > > - This patch set also tweaks the commit_rewrite_person() so that it is > > easier to understand and avoids unnecessary parsing of the buffer > > wherever possible. > > > > Siddharth Asthana (4): > > revision: improve commit_rewrite_person() > > ident: move commit_rewrite_person() to ident.c > > ident: rename commit_rewrite_person() to apply_mailmap_to_header() > > cat-file: add mailmap support > > > > Documentation/git-cat-file.txt | 6 +++ > > builtin/cat-file.c | 43 +++++++++++++++++++- > > cache.h | 6 +++ > > ident.c | 74 ++++++++++++++++++++++++++++++++++ > > revision.c | 50 ++--------------------- > > t/t4203-mailmap.sh | 59 +++++++++++++++++++++++++++ > > 6 files changed, 190 insertions(+), 48 deletions(-) > > I haven't seen any comments or objections to this round. Are people > happy about it going forward? I am planning to merge it to 'next' > and down to 'master' soonish.
I am biased, but I am happy with the current state of this patch series. During the last versions of this patch series there were only comments related to the first patch in the series (revision: improve commit_rewrite_person()). It seems to me that they were all properly taken into account, and that the code in that patch is now correct and relatively simple to understand.
Thanks, Christian.