Re: [PATCH 06/18] streaming: create structure for in-core object streams
On Wed, Nov 19, 2025 at 10:14:28AM +0000, Karthik Nayak wrote:
Show 20 quoted lines
> Patrick Steinhardt <ps@pks.im> writes:
> > @@ -426,22 +429,24 @@ static int open_istream_incore(struct odb_read_stream **out,
> > const struct object_id *oid)
> > {
> > struct object_info oi = OBJECT_INFO_INIT;
> > - struct odb_read_stream stream = {
> > - .close = close_istream_incore,
> > - .read = read_istream_incore,
> > - };
> > + struct odb_incore_read_stream stream = {
> > + .base.close = close_istream_incore,
> > + .base.read = read_istream_incore,
> > + }, *st;
>
> Nit: Almost missed this `*st`. I wonder if its more readable as a
> separate line:
>
> struct odb_incore_read_stream *st;
>
> All good otherwise.