git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 05/18] streaming: allocate stream inside the backend-specific logic

From
Karthik Nayak <karthik.188@gmail.com>
Date
Nov 19, 2025, 10:11 UTC
Message-ID
<CAOLa=ZTF+xzhZv2yXp8L_URk8cjscycheD=Xgdxd=eRGtvpt2A@mail.gmail.com>
In-Reply-To
<20251119-b4-pks-odb-read-stream-v1-5-adacf03c2ccf@pks.im>
Patrick Steinhardt <ps@pks.im> writes:
Show 9 quoted lines
> When creating a new stream we first allocate it and then call into
> backend-specific logic to populate the stream. This design requires that
> the stream itself contains a `union` with backend-specific members that
> then ultimately get populated by the backend-specific logic.
>
> This works, but it's awkward in the context of pluggable object
> databases. Each backend will need its own member in that union, and as
> the structure itself is completely opaque (it's only defined in
> "streamgin.c") it also has the consequence that we must have the logic
s/streamgin/streaming
Show 7 quoted lines
> that is specific to backends in "streaming.c".
>
> Ideally though, the infrastructure would be reversed: we have a generic
> `struct odb_read_stream` and some helper functions in "streaming.c",
> whereas the backend-specific logic sits in the backend's subsystem
> itself.
>

Will this also mean that we move the backend specific functions like `open_istream_loose()` away from 'streaming.c'? Let's read on.

Show 7 quoted lines
> This can be realized by using a design that is similar to how we handle
> reference databases: instead of having a union of members, we instead
> have backend-specific structures with a `struct odb_read_stream base`
> as its first member. The backends would thus hand out the pointer to the
> base, but internally they know to cast back to the backend-specific
> type.
>
Right.
Show 5 quoted lines
> This means though that we need to allocate different structures
> depending on the backend. To prepare for this, move allocation of the
> structure into the backend-specific functions that open a new stream.
> Subsequent commits will then create those new backend-specific structs.
>

Who's in charge of free'ing these structs? I see that `close_istream()` calls the assigned `close()` function. So this could be handled on the backend level. But it also does `free(st)`.

Show 16 quoted lines
> Signed-off-by: Patrick Steinhardt <ps@pks.im>
> ---
>  streaming.c | 99 +++++++++++++++++++++++++++++++++++++++----------------------
>  1 file changed, 63 insertions(+), 36 deletions(-)
>
> diff --git a/streaming.c b/streaming.c
> index d7db446d25..b8ce82483f 100644
> --- a/streaming.c
> +++ b/streaming.c
> @@ -222,27 +222,34 @@ static int close_istream_loose(struct odb_read_stream *st)
>  	return 0;
>  }
>
> -static int open_istream_loose(struct odb_read_stream *st, struct repository *r,
> +static int open_istream_loose(struct odb_read_stream **out,
> +			      struct repository *r,

We take in a double pointer now, since the allocation will be handled inside the function.

Show 82 quoted lines
>  			      const struct object_id *oid)
>  {
>  	struct object_info oi = OBJECT_INFO_INIT;
> +	struct odb_read_stream *st;
>  	struct odb_source *source;
> -
> -	oi.sizep = &st->size;
> -	oi.typep = &st->type;
> +	unsigned long mapsize;
> +	void *mapped;
>
>  	odb_prepare_alternates(r->objects);
>  	for (source = r->objects->sources; source; source = source->next) {
> -		st->u.loose.mapped = odb_source_loose_map_object(source, oid,
> -								 &st->u.loose.mapsize);
> -		if (st->u.loose.mapped)
> +		mapped = odb_source_loose_map_object(source, oid, &mapsize);
> +		if (mapped)
>  			break;
>  	}
> -	if (!st->u.loose.mapped)
> +	if (!mapped)
>  		return -1;
>
> -	switch (unpack_loose_header(&st->z, st->u.loose.mapped,
> -				    st->u.loose.mapsize, st->u.loose.hdr,
> +	/*
> +	 * Note: we must allocate this structure early even though we may still
> +	 * fail. This is because we need to initialize the zlib stream, and it
> +	 * is not possible to copy the stream around after the fact because it
> +	 * has self-referencing pointers.
> +	 */
> +	CALLOC_ARRAY(st, 1);
> +
> +	switch (unpack_loose_header(&st->z, mapped, mapsize, st->u.loose.hdr,
>  				    sizeof(st->u.loose.hdr))) {
>  	case ULHR_OK:
>  		break;
> @@ -250,19 +257,28 @@ static int open_istream_loose(struct odb_read_stream *st, struct repository *r,
>  	case ULHR_TOO_LONG:
>  		goto error;
>  	}
> +
> +	oi.sizep = &st->size;
> +	oi.typep = &st->type;
> +
>  	if (parse_loose_header(st->u.loose.hdr, &oi) < 0 || st->type < 0)
>  		goto error;
>
> +	st->u.loose.mapped = mapped;
> +	st->u.loose.mapsize = mapsize;
>  	st->u.loose.hdr_used = strlen(st->u.loose.hdr) + 1;
>  	st->u.loose.hdr_avail = st->z.total_out;
>  	st->z_state = z_used;
>  	st->close = close_istream_loose;
>  	st->read = read_istream_loose;
>
> +	*out = st;
> +
>  	return 0;
>  error:
>  	git_inflate_end(&st->z);
>  	munmap(st->u.loose.mapped, st->u.loose.mapsize);
> +	free(st);
>  	return -1;
>  }
>
> @@ -338,12 +354,16 @@ static int close_istream_pack_non_delta(struct odb_read_stream *st)
>  	return 0;
>  }
>
> -static int open_istream_pack_non_delta(struct odb_read_stream *st,
> +static int open_istream_pack_non_delta(struct odb_read_stream **out,
>  				       struct repository *r UNUSED,
>  				       const struct object_id *oid UNUSED,
>  				       struct packed_git *pack,
>  				       off_t offset)
>  {
> +	struct odb_read_stream stream = {
> +		.close = close_istream_pack_non_delta,
> +		.read = read_istream_pack_non_delta,
> +	};
So this is now statically defined. Won't this cause an issue?
The rest looks good. Thanks
Previous: Patrick SteinhardtNext: Patrick Steinhardt
Message 15 of 85 in “Refactor object read streams to work via object sources”
  1. 00/18 Refactor object read streams to work via object sourcesPatrick Steinhardt, Nov 19, 2025
  2. 01/18 streaming: rename `git_istream` into `odb_read_stream`Patrick Steinhardt, Nov 19, 2025
  3. Justin ToblerNov 19, 2025
  4. Junio C HamanoNov 19, 2025
  5. Patrick SteinhardtNov 21, 2025
  6. 02/18 streaming: drop the `open()` callback functionPatrick Steinhardt, Nov 19, 2025
  7. Karthik NayakNov 19, 2025
  8. Justin ToblerNov 19, 2025
  9. Patrick SteinhardtNov 21, 2025
  10. 03/18 streaming: propagate final object type via the streamPatrick Steinhardt, Nov 19, 2025
  11. Justin ToblerNov 19, 2025
  12. Patrick SteinhardtNov 21, 2025
  13. 04/18 streaming: explicitly pass packfile info when streaming a packed objectPatrick Steinhardt, Nov 19, 2025
  14. 05/18 streaming: allocate stream inside the backend-specific logicPatrick Steinhardt, Nov 19, 2025
  15. Karthik NayakNov 19, 2025
  16. Patrick SteinhardtNov 21, 2025
  17. 06/18 streaming: create structure for in-core object streamsPatrick Steinhardt, Nov 19, 2025
  18. Karthik NayakNov 19, 2025
  19. Patrick SteinhardtNov 21, 2025
  20. 07/18 streaming: create structure for loose object streamsPatrick Steinhardt, Nov 19, 2025
  21. 08/18 streaming: create structure for packed object streamsPatrick Steinhardt, Nov 19, 2025
  22. 09/18 streaming: create structure for filtered object streamsPatrick Steinhardt, Nov 19, 2025
  23. 10/18 streaming: move zlib stream into backendsPatrick Steinhardt, Nov 19, 2025
  24. 11/18 packfile: introduce function to read object info from a storePatrick Steinhardt, Nov 19, 2025
  25. Karthik NayakNov 19, 2025
  26. Patrick SteinhardtNov 21, 2025
  27. 12/18 streaming: rely on object sources to create object streamPatrick Steinhardt, Nov 19, 2025
  28. Karthik NayakNov 19, 2025
  29. 13/18 streaming: get rid of `the_repository`Patrick Steinhardt, Nov 19, 2025
  30. 14/18 streaming: make the `odb_read_stream` definition publicPatrick Steinhardt, Nov 19, 2025
  31. Karthik NayakNov 19, 2025
  32. Patrick SteinhardtNov 21, 2025
  33. 15/18 streaming: move logic to read loose objects streams into backendPatrick Steinhardt, Nov 19, 2025
  34. 16/18 streaming: move logic to read packed objects streams into backendPatrick Steinhardt, Nov 19, 2025
  35. 17/18 streaming: refactor interface to be object-database-centricPatrick Steinhardt, Nov 19, 2025
  36. 18/18 streaming: move into object database subsystemPatrick Steinhardt, Nov 19, 2025
  37. 00/19 Refactor object read streams to work via object sourcesPatrick Steinhardt, Nov 21, 2025
  38. 01/19 streaming: rename `git_istream` into `odb_read_stream`Patrick Steinhardt, Nov 21, 2025
  39. 02/19 streaming: drop the `open()` callback functionPatrick Steinhardt, Nov 21, 2025
  40. Junio C HamanoNov 21, 2025
  41. Patrick SteinhardtNov 23, 2025
  42. 03/19 streaming: propagate final object type via the streamPatrick Steinhardt, Nov 21, 2025
  43. 04/19 streaming: explicitly pass packfile info when streaming a packed objectPatrick Steinhardt, Nov 21, 2025
  44. 05/19 streaming: allocate stream inside the backend-specific logicPatrick Steinhardt, Nov 21, 2025
  45. 06/19 streaming: create structure for in-core object streamsPatrick Steinhardt, Nov 21, 2025
  46. 07/19 streaming: create structure for loose object streamsPatrick Steinhardt, Nov 21, 2025
  47. 08/19 streaming: create structure for packed object streamsPatrick Steinhardt, Nov 21, 2025
  48. 09/19 streaming: create structure for filtered object streamsPatrick Steinhardt, Nov 21, 2025
  49. 10/19 streaming: move zlib stream into backendsPatrick Steinhardt, Nov 21, 2025
  50. 11/19 packfile: introduce function to read object info from a storePatrick Steinhardt, Nov 21, 2025
  51. 12/19 streaming: rely on object sources to create object streamPatrick Steinhardt, Nov 21, 2025
  52. Junio C HamanoNov 21, 2025
  53. Patrick SteinhardtNov 23, 2025
  54. 13/19 streaming: get rid of `the_repository`Patrick Steinhardt, Nov 21, 2025
  55. Junio C HamanoNov 21, 2025
  56. Patrick SteinhardtNov 23, 2025
  57. 14/19 streaming: make the `odb_read_stream` definition publicPatrick Steinhardt, Nov 21, 2025
  58. 15/19 streaming: move logic to read loose objects streams into backendPatrick Steinhardt, Nov 21, 2025
  59. 16/19 streaming: move logic to read packed objects streams into backendPatrick Steinhardt, Nov 21, 2025
  60. 17/19 streaming: refactor interface to be object-database-centricPatrick Steinhardt, Nov 21, 2025
  61. Junio C HamanoNov 22, 2025
  62. Patrick SteinhardtNov 23, 2025
  63. 18/19 streaming: move into object database subsystemPatrick Steinhardt, Nov 21, 2025
  64. Junio C HamanoNov 23, 2025
  65. 19/19 streaming: drop redundant type and size pointersPatrick Steinhardt, Nov 21, 2025
  66. 00/19 Refactor object read streams to work via object sourcesPatrick Steinhardt, Nov 23, 2025
  67. 01/19 streaming: rename `git_istream` into `odb_read_stream`Patrick Steinhardt, Nov 23, 2025
  68. 02/19 streaming: drop the `open()` callback functionPatrick Steinhardt, Nov 23, 2025
  69. 03/19 streaming: propagate final object type via the streamPatrick Steinhardt, Nov 23, 2025
  70. 04/19 streaming: explicitly pass packfile info when streaming a packed objectPatrick Steinhardt, Nov 23, 2025
  71. 05/19 streaming: allocate stream inside the backend-specific logicPatrick Steinhardt, Nov 23, 2025
  72. 06/19 streaming: create structure for in-core object streamsPatrick Steinhardt, Nov 23, 2025
  73. 07/19 streaming: create structure for loose object streamsPatrick Steinhardt, Nov 23, 2025
  74. 08/19 streaming: create structure for packed object streamsPatrick Steinhardt, Nov 23, 2025
  75. 09/19 streaming: create structure for filtered object streamsPatrick Steinhardt, Nov 23, 2025
  76. 10/19 streaming: move zlib stream into backendsPatrick Steinhardt, Nov 23, 2025
  77. 11/19 packfile: introduce function to read object info from a storePatrick Steinhardt, Nov 23, 2025
  78. 12/19 streaming: rely on object sources to create object streamPatrick Steinhardt, Nov 23, 2025
  79. 13/19 streaming: get rid of `the_repository`Patrick Steinhardt, Nov 23, 2025
  80. 14/19 streaming: make the `odb_read_stream` definition publicPatrick Steinhardt, Nov 23, 2025
  81. 15/19 streaming: move logic to read loose objects streams into backendPatrick Steinhardt, Nov 23, 2025
  82. 16/19 streaming: move logic to read packed objects streams into backendPatrick Steinhardt, Nov 23, 2025
  83. 17/19 streaming: refactor interface to be object-database-centricPatrick Steinhardt, Nov 23, 2025
  84. 18/19 streaming: move into object database subsystemPatrick Steinhardt, Nov 23, 2025
  85. 19/19 streaming: drop redundant type and size pointersPatrick Steinhardt, Nov 23, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.