Re: [PATCH 01/18] streaming: rename `git_istream` into `odb_read_stream`
On Wed, Nov 19, 2025 at 12:49:22PM -0600, Justin Tobler wrote:
Show 14 quoted lines
> On 25/11/19 08:47AM, Patrick Steinhardt wrote:
> > diff --git a/streaming.h b/streaming.h
> > index bd27f59e57..acf4c84338 100644
> > --- a/streaming.h
> > +++ b/streaming.h
> > @@ -7,14 +7,14 @@
> > #include "object.h"
> >
> > /* opaque */
> > -struct git_istream;
> > +struct odb_read_stream;
>
> The name change here makes sense. While we are here, it might be nice to
> leave a comment annotating it's purpose in a bit more detail.
I do this in a subsequent commit, so I won't add this comment here.
Patrick