git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 08/10] t-reftable-block: add tests for log blocks

From
Patrick Steinhardt <ps@pks.im>
Date
Aug 16, 2024, 07:42 UTC
Message-ID
<Zr8C0ir5UHzaHfUq@tanuki>
In-Reply-To
<CA+J6zkSOF-RtrBvgunMsTdL4Qd8H10zUHesXYtYG8DW+kJht-w@mail.gmail.com>
On Fri, Aug 16, 2024 at 12:06:47AM +0530, Chandra Pratap wrote:
Show 54 quoted lines
> On Thu, 15 Aug 2024 at 15:11, Patrick Steinhardt <ps@pks.im> wrote:
> >
> > On Wed, Aug 14, 2024 at 05:33:16PM +0530, Chandra Pratap wrote:
> > > @@ -101,9 +101,95 @@ static void t_block_read_write(void)
> > >               reftable_record_release(&recs[i]);
> > >  }
> > >
> > > +static void t_log_block_read_write(void)
> > > +{
> > > +     const int header_off = 21;
> > > +     struct reftable_record recs[30];
> > > +     const size_t N = ARRAY_SIZE(recs);
> > > +     const size_t block_size = 2048;
> > > +     struct reftable_block block = { 0 };
> > > +     struct block_writer bw = {
> > > +             .last_key = STRBUF_INIT,
> > > +     };
> > > +     struct reftable_record rec = {
> > > +             .type = BLOCK_TYPE_LOG,
> > > +     };
> > > +     size_t i = 0;
> > > +     int n;
> > > +     struct block_reader br = { 0 };
> > > +     struct block_iter it = BLOCK_ITER_INIT;
> > > +     struct strbuf want = STRBUF_INIT;
> > > +
> > > +     REFTABLE_CALLOC_ARRAY(block.data, block_size);
> > > +     block.len = block_size;
> > > +     block.source = malloc_block_source();
> > > +     block_writer_init(&bw, BLOCK_TYPE_LOG, block.data, block_size,
> > > +                       header_off, hash_size(GIT_SHA1_FORMAT_ID));
> > > +
> > > +     for (i = 0; i < N; i++) {
> > > +             rec.u.log.refname = xstrfmt("branch%02"PRIuMAX , (uintmax_t)i);
> > > +             rec.u.log.update_index = i;
> > > +             rec.u.log.value_type = REFTABLE_LOG_UPDATE;
> > > +
> > > +             recs[i] = rec;
> > > +             n = block_writer_add(&bw, &rec);
> > > +             rec.u.log.refname = NULL;
> > > +             rec.u.log.value_type = REFTABLE_LOG_DELETION;
> > > +             check_int(n, ==, 0);
> > > +     }
> > > +
> > > +     n = block_writer_finish(&bw);
> > > +     check_int(n, >, 0);
> >
> > Do we maybe want to rename `n` to `ret`? That's way more customary in
> > our codebase.
> 
> Sure thing, but then I would want to change the existing test (which gets
> renamed as t_ref_block_read_write) and I'm unsure of which patch would
> be the most suitable for that change. Would it be fine to include that
> change as a part of this patch?

The way I'd do it is to first do the minimum required changes to port the old test to the new testing framework, without any of the cleanups to align code style. Then I'd put another commit on top that does all the changes like removing braces, converting types and also adapting names.

Show 28 quoted lines
> > > +     block_writer_release(&bw);
> > > +
> > > +     block_reader_init(&br, &block, header_off, block_size, GIT_SHA1_RAWSZ);
> > > +
> > > +     block_iter_seek_start(&it, &br);
> > > +
> > > +     for (i = 0; ; i++) {
> > > +             int r = block_iter_next(&it, &rec);
> > > +             check_int(r, >=, 0);
> > > +             if (r > 0)
> > > +                     break;
> >
> > We can also reuse `n` (or `ret`) here, right?
> >
> > > +             check(reftable_record_equal(&recs[i], &rec, GIT_SHA1_RAWSZ));
> > > +     }
> >
> > One thing that this loop doesn't verify is whether we actually got the
> > expected number of log records. It could be that the first iteration
> > already returns `r > 0`, which is not our expectation. So we should
> > likely add a check for `i == N` after the loop.
> 
> What about something like
> if (r > 0) {
>     check_int(i, ==, N);
>     break;
> }
> That should achieve the same results if I'm not wrong.
Yup, looks good to me.
Patrick
Previous: Chandra PratapNext: Chandra Pratap
Message 17 of 53 in “t: port reftable/block_test.c to the unit testing framework”
  1. Chandra PratapAug 14, 2024
  2. 01/10 t: move reftable/block_test.c to the unit testing frameworkChandra Pratap, Aug 14, 2024
  3. 02/10 t-reftable-block: release used block readerChandra Pratap, Aug 14, 2024
  4. Patrick SteinhardtAug 15, 2024
  5. Chandra PratapAug 15, 2024
  6. 03/10 t-reftable-block: use reftable_record_equal() instead of check_str()Chandra Pratap, Aug 14, 2024
  7. Patrick SteinhardtAug 15, 2024
  8. 04/10 t-reftable-block: use reftable_record_key() instead of strbuf_addstr()Chandra Pratap, Aug 14, 2024
  9. Patrick SteinhardtAug 15, 2024
  10. 05/10 t-reftable-block: use block_iter_reset() instead of block_iter_close()Chandra Pratap, Aug 14, 2024
  11. Patrick SteinhardtAug 15, 2024
  12. 06/10 t-reftable-block: use xstrfmt() instead of xstrdup()Chandra Pratap, Aug 14, 2024
  13. 07/10 t-reftable-block: remove unnecessary variable 'j'Chandra Pratap, Aug 14, 2024
  14. 08/10 t-reftable-block: add tests for log blocksChandra Pratap, Aug 14, 2024
  15. Patrick SteinhardtAug 15, 2024
  16. Chandra PratapAug 15, 2024
  17. Patrick SteinhardtAug 16, 2024
  18. 09/10 t-reftable-block: add tests for obj blocksChandra Pratap, Aug 14, 2024
  19. Patrick SteinhardtAug 15, 2024
  20. Chandra PratapAug 15, 2024
  21. Patrick SteinhardtAug 16, 2024
  22. 10/10 t-reftable-block: add tests for index blocksChandra Pratap, Aug 14, 2024
  23. Patrick SteinhardtAug 15, 2024
  24. [GSoC][PATCH v2 00/11] t: port reftable/block_test.c to the unit testing frameworkChandra Pratap, Aug 16, 2024
  25. 01/11 t: move reftable/block_test.c to the unit testing frameworkChandra Pratap, Aug 16, 2024
  26. 02/11 t: harmonize t-reftable-block.c with coding guidelinesChandra Pratap, Aug 16, 2024
  27. 03/11 t-reftable-block: release used block readerChandra Pratap, Aug 16, 2024
  28. 04/11 t-reftable-block: use reftable_record_equal() instead of check_str()Chandra Pratap, Aug 16, 2024
  29. 05/11 t-reftable-block: use reftable_record_key() instead of strbuf_addstr()Chandra Pratap, Aug 16, 2024
  30. 06/11 t-reftable-block: use block_iter_reset() instead of block_iter_close()Chandra Pratap, Aug 16, 2024
  31. 07/11 t-reftable-block: use xstrfmt() instead of xstrdup()Chandra Pratap, Aug 16, 2024
  32. 08/11 t-reftable-block: remove unnecessary variable 'j'Chandra Pratap, Aug 16, 2024
  33. 09/11 t-reftable-block: add tests for log blocksChandra Pratap, Aug 16, 2024
  34. Patrick SteinhardtAug 21, 2024
  35. Junio C HamanoAug 21, 2024
  36. 10/11 t-reftable-block: add tests for obj blocksChandra Pratap, Aug 16, 2024
  37. Chandra PratapAug 16, 2024
  38. 11/11 t-reftable-block: add tests for index blocksChandra Pratap, Aug 16, 2024
  39. Chandra PratapAug 21, 2024
  40. [GSoC][PATCH v3 00/11] t: port reftable/block_test.c to the unit testing frameworkChandra Pratap, Aug 21, 2024
  41. 01/11 t: move reftable/block_test.c to the unit testing frameworkChandra Pratap, Aug 21, 2024
  42. 02/11 t: harmonize t-reftable-block.c with coding guidelinesChandra Pratap, Aug 21, 2024
  43. 03/11 t-reftable-block: release used block readerChandra Pratap, Aug 21, 2024
  44. 04/11 t-reftable-block: use reftable_record_equal() instead of check_str()Chandra Pratap, Aug 21, 2024
  45. 05/11 t-reftable-block: use reftable_record_key() instead of strbuf_addstr()Chandra Pratap, Aug 21, 2024
  46. 06/11 t-reftable-block: use block_iter_reset() instead of block_iter_close()Chandra Pratap, Aug 21, 2024
  47. 07/11 t-reftable-block: use xstrfmt() instead of xstrdup()Chandra Pratap, Aug 21, 2024
  48. 08/11 t-reftable-block: remove unnecessary variable 'j'Chandra Pratap, Aug 21, 2024
  49. 09/11 t-reftable-block: add tests for log blocksChandra Pratap, Aug 21, 2024
  50. 10/11 t-reftable-block: add tests for obj blocksChandra Pratap, Aug 21, 2024
  51. 11/11 t-reftable-block: add tests for index blocksChandra Pratap, Aug 21, 2024
  52. Patrick SteinhardtAug 22, 2024
  53. Junio C HamanoAug 22, 2024

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.