Re: [PATCH 5/9] serve: provide "receive" function for session-id capability
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Sep 14, 2021, 17:12 UTC
- Message-ID
- <YUDYB0kQQsbKyIH9@nand.local>
- In-Reply-To
- <YUDWoiN7wczfNwU8@coredump.intra.peff.net>
On Tue, Sep 14, 2021 at 01:06:42PM -0400, Jeff King wrote:
Show 16 quoted lines
> On Tue, Sep 14, 2021 at 12:55:01PM -0400, Taylor Blau wrote: > > > On Tue, Sep 14, 2021 at 11:33:09AM -0400, Jeff King wrote: > > > I had originally dropped has_capability() in a separate patch, to keep > > > this one more readable. That breaks bisectability, but only with > > > -Werror. I'm not sure where we should fall on that spectrum (I generally > > > bisect with -Wno-error just because warnings may come and go when > > > working with different compilers than what was normal at the time). > > > > I tend to fall the same way, especially when bisecting things in ancient > > (to me) versions of Git where my current compiler complains. So I think > > the approach that you took here is just fine. > > To be clear, the approach here is conservative: it will bisect even with > -Werror. I think what you're saying is I _could_ have done the other > approach, and put the removal into its own commit?
Yes. I would have been fine with dropping has_capability() in its own patch, since the result would have been more readable (and since I never bisect with `-Werror`). But this (the conservative approach of persevering bisect-ability even with `-Werror` is fine with me, too).
> -Peff
Thanks, Taylor