[PATCH 1/9] serve: rename is_command() to parse_command()
- From
Jeff King <peff@peff.net>
- Date
- Sep 14, 2021, 15:30 UTC
- Message-ID
- <YUDADFmF0K6xhX6E@coredump.intra.peff.net>
- In-Reply-To
- <YUC/6n1hhUbMJiLw@coredump.intra.peff.net>
The is_command() function not only tells us whether the pktline is a valid command string, but it also parses out the command (and complains if we see a duplicate). Let's rename it to make those extra functions a bit more obvious.
Signed-off-by: Jeff King <peff@peff.net> --- Obviously not strictly necessary, but the name caused me a fair bit of confusion at first while touching this code.
serve.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/serve.c b/serve.c index 1817edc7f5..fd88b95343 100644 --- a/serve.c +++ b/serve.c @@ -163,7 +163,7 @@ static int is_valid_capability(const char *key) return c && c->advertise(the_repository, NULL); } -static int is_command(const char *key, struct protocol_capability **command) +static int parse_command(const char *key, struct protocol_capability **command) { const char *out; @@ -251,7 +251,7 @@ static int process_request(void) BUG("Should have already died when seeing EOF"); case PACKET_READ_NORMAL: /* collect request; a sequence of keys and values */ - if (is_command(reader.line, &command) || + if (parse_command(reader.line, &command) || is_valid_capability(reader.line)) strvec_push(&keys, reader.line); else
-- 2.33.0.887.g5b1f44e68d