Re: [PATCH 3/4] repack: use tempfiles for signal cleanup
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Oct 21, 2022, 23:45 UTC
- Message-ID
- <Y1MvGIVz9bTTsS25@nand.local>
- In-Reply-To
- <Y1MqPjnYoWcOgXo6@coredump.intra.peff.net>
On Fri, Oct 21, 2022 at 07:24:46PM -0400, Jeff King wrote:
Show 54 quoted lines
> On Fri, Oct 21, 2022 at 03:30:29PM -0700, Junio C Hamano wrote:
>
> > > @@ -867,8 +860,6 @@ int cmd_repack(int argc, const char **argv, const char *prefix)
> > > split_pack_geometry(geometry, geometric_factor);
> > > }
> > >
> > > - sigchain_push_common(remove_pack_on_signal);
> > > -
> > > prepare_pack_objects(&cmd, &po_args);
> > >
> > > show_progress = !po_args.quiet && isatty(2);
> > > @@ -1020,14 +1011,14 @@ int cmd_repack(int argc, const char **argv, const char *prefix)
> > > fname_old = mkpathdup("%s-%s%s",
> > > packtmp, item->string, exts[ext].name);
> > >
> > > - if (data->exts[ext]) {
> > > + if (data->tempfiles[ext]) {
> > > struct stat statbuffer;
> > > if (!stat(fname_old, &statbuffer)) {
> > > statbuffer.st_mode &= ~(S_IWUSR | S_IWGRP | S_IWOTH);
> > > chmod(fname_old, statbuffer.st_mode);
> > > }
> > >
> > > - if (rename(fname_old, fname))
> > > + if (rename_tempfile(&data->tempfiles[ext], fname))
> > > die_errno(_("renaming '%s' failed"), fname_old);
> >
> > It now got a bit confusing that we have 'fname', 'fname_old', and
> > the tempfile. The path.buf used as the argument to register_tempfile()
> > matches what is used to compute fname_old above. I wonder if tempfile
> > API does not give us that name so that we can stop using fname_old here?
>
> It does, and we probably should use get_tempfile_path() in the error
> message here. But sadly we can't get rid of fname_old entirely, as it's
> used below this for the second block in the if-else chain:
>
> if (data->tempfiles[ext]) {
> ...do the rename ...
> } else if (!exts[ext].optional)
> die(_("missing required file: %s"), fname_old);
> else if (unlink(fname) < 0 && errno != ENOENT)
> die_errno(_("could not unlink: %s"), fname);
>
> OTOH, it would probably be equally readable (or perhaps even better) for
> that second block to say:
>
> die("pack-objects did not generate a '%s' file for pack %s",
> exts[ext].name, item->string);
>
> And then we could drop fname_old entirely. Which is nice, because it
> gets rid of the implicit assumption that the tempfile matches what is in
> fname_old (which is always true, but since they are generated by
> individual lines far apart from each other, it's possible for that to
> change).TBH, I've always found fname_old to be a confusing name. It's not really "old", in fact we just had pack-objects write that file ;-). It really does pertain to the tempfile, and I think using get_tempfile_path() when we have a tempfile to rename is sensible.
I think that your proposed error message is good, too, and doubly so since it lets us get rid of fname_old entirely. Yay :-).
> -Peff
Thanks, Taylor