Re: [PATCH/RFC v2 1/4] Add "core.eolStyle" variable to control end-of-line conversion
- From
Eyvind Bernhardsen <eyvind.bernhardsen@gmail.com>
- Date
- May 8, 2010, 22:17 UTC
- Message-ID
- <E2A9C4D2-010F-44B2-BF6A-627DE8B72FB5@gmail.com>
- In-Reply-To
- <alpine.LFD.2.00.1005081455450.3711@i5.linux-foundation.org>
On 8. mai 2010, at 23.57, Linus Torvalds <torvalds@linux- foundation.org> wrote:
> Having two config variables named "core.autocrlf" and "core.crlf" at > least > is consistent. Having "autocrlf" and "eolStyle" is just messed up.
I see your point, but "crlf=lf" makes no sense and "crlf=input" is hideous. It's bad enough that autocrlf uses "true" and "input"; this is a chance to reduce the insanity, not perpetuate it.
I'll try to think of a better name.
-- Eyvind