Re: [PATCH/RFC v2 1/4] Add "core.eolStyle" variable to control end-of-line conversion
- From
Linus Torvalds <torvalds@linux-foundation.org>
- Date
- May 8, 2010, 21:57 UTC
- Message-ID
- <alpine.LFD.2.00.1005081455450.3711@i5.linux-foundation.org>
- In-Reply-To
- <c8ef28b72709013f17e093954a0f4e2ad1fb9652.1273352819.git.eyvind.bernhardsen@gmail.com>
On Sat, 8 May 2010, Eyvind Bernhardsen wrote:
Show 5 quoted lines
> > Introduce a new configuration variable, "core.eolStyle", that allows the > user to set which line endings to use for end-of-line-normalized files > in the working directory. It defaults to "native", which means CRLF on > Windows and LF everywhere else.
So I at least agree with the semantics now, but I think that we really would be better off just calling it "core.crlf". I don't _care_ whether people think it's a bad name - much worse than a bad name is to use a name that is not consistent.
Having two config variables named "core.autocrlf" and "core.crlf" at least is consistent. Having "autocrlf" and "eolStyle" is just messed up.
Linus