Re: [PATCH 53/83] builtin/apply: make find_header() return -1 instead of die()ing
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Apr 27, 2016, 18:10 UTC
- Message-ID
- <CAPig+cSdRL3hc81pXXFKAZWisGYPHcd47Z4BBhkeSWZ=5_FT9A@mail.gmail.com>
- In-Reply-To
- <CACsJy8B7g8WgWbr4M4LHFyBshN2gi30pL1bCcZcTPB7qtmnWdQ@mail.gmail.com>
On Mon, Apr 25, 2016 at 9:18 AM, Duy Nguyen <pclouds@gmail.com> wrote:
Show 11 quoted lines
> On Sun, Apr 24, 2016 at 8:33 PM, Christian Couder > <christian.couder@gmail.com> wrote: >> To be compatible with the rest of the error handling in builtin/apply.c, >> find_header() should return -1 instead of calling die(). >> >> Unfortunately find_header() already returns -1 when no header is found, >> so let's make it return -2 instead in this case. > > I don't think this is a good way to go. Too many magic numbers. I > don't have a better option though. Maybe returning names instead of > numbers would help a bit.
I suppose 'hdrsize' could signal this extra condition. For instance, always return -1 on error, and set hdrsize to 0 for header not found (unless 0 is a valid size?), and -1 for any other error.
But perhaps that's getting too clever...