Re: [PATCH 5/9] t7450: test verify_path() handling of gitmodules
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- May 1, 2021, 19:03 UTC
- Message-ID
- <CAPig+cQFUUncb17MFAvJAh2KFxK_OCq_6AoOwPViYyQJUDVJNg@mail.gmail.com>
- In-Reply-To
- <CAPig+cSxB89mJcjaoLMLEgqdqi9SSP5+R9qjbVydvA-kVq-2+g@mail.gmail.com>
On Sat, May 1, 2021 at 2:55 PM Eric Sunshine <sunshine@sunshineco.com> wrote:
Show 8 quoted lines
> On Sat, May 1, 2021 at 11:42 AM Jeff King <peff@peff.net> wrote: > > + tree=$(git -C symlink mktree <symlink/bad-tree) > > `tree` is an unusually generic name for this now-global variable. One > can easily imagine it being re-used by some unrelated test arbitrarily > inserted into this script, thus potentially breaking the following > tests which depend upon it. I wonder if a name such as `BAD_TREE` > would be more appropriate.
I see that all `$tree` references get encapsulated into a shell function by the next patch, so perhaps the generic name `tree` isn't a big deal after all.