From: Eric Sunshine Date: Sat, 01 May 2021 19:03:56 GMT Subject: Re: [PATCH 5/9] t7450: test verify_path() handling of gitmodules Message-ID: In-Reply-To: On Sat, May 1, 2021 at 2:55 PM Eric Sunshine wrote: > On Sat, May 1, 2021 at 11:42 AM Jeff King wrote: > > + tree=$(git -C symlink mktree > `tree` is an unusually generic name for this now-global variable. One > can easily imagine it being re-used by some unrelated test arbitrarily > inserted into this script, thus potentially breaking the following > tests which depend upon it. I wonder if a name such as `BAD_TREE` > would be more appropriate. I see that all `$tree` references get encapsulated into a shell function by the next patch, so perhaps the generic name `tree` isn't a big deal after all.