Re: [PATCH 5/9] t7450: test verify_path() handling of gitmodules
- From
Jeff King <peff@peff.net>
- Date
- May 3, 2021, 19:39 UTC
- Message-ID
- <YJBRVQ7+CUkYf5Us@coredump.intra.peff.net>
- In-Reply-To
- <CAPig+cQFUUncb17MFAvJAh2KFxK_OCq_6AoOwPViYyQJUDVJNg@mail.gmail.com>
On Sat, May 01, 2021 at 03:03:56PM -0400, Eric Sunshine wrote:
Show 13 quoted lines
> On Sat, May 1, 2021 at 2:55 PM Eric Sunshine <sunshine@sunshineco.com> wrote: > > On Sat, May 1, 2021 at 11:42 AM Jeff King <peff@peff.net> wrote: > > > + tree=$(git -C symlink mktree <symlink/bad-tree) > > > > `tree` is an unusually generic name for this now-global variable. One > > can easily imagine it being re-used by some unrelated test arbitrarily > > inserted into this script, thus potentially breaking the following > > tests which depend upon it. I wonder if a name such as `BAD_TREE` > > would be more appropriate. > > I see that all `$tree` references get encapsulated into a shell > function by the next patch, so perhaps the generic name `tree` isn't a > big deal after all.
Yeah. I'd like to think it is not that big a deal between even just adjacent tests, because anybody adding tests in the middle of a script would take care not to split related ones. But that may be too optimistic. ;)
At any rate, it seems OK to assume the function will all be used together.
-Peff