Re: [PATCH 2/8] update-index: use enum for untracked cache options
- From
Christian Couder <christian.couder@gmail.com>
- Date
- Dec 12, 2015, 09:25 UTC
- Message-ID
- <CAP8UFD24Xm6bVYYJShDXui=ot+YpScaGZ9HC3K+Rqem3y1Rn0w@mail.gmail.com>
- In-Reply-To
- <xmqqio44g9rm.fsf@gitster.mtv.corp.google.com>
On Fri, Dec 11, 2015 at 6:44 PM, Junio C Hamano <gitster@pobox.com> wrote:
Show 20 quoted lines
> Christian Couder <christian.couder@gmail.com> writes: > >>> As you know I am bad at bikeshedding; the only suggestion in the >>> above is to have common UC_ prefix ;-) Don't take what follow UC_ >>> as my suggestion. >> >> I am bad at finding names too, so I think what you wrote is pretty good. >> >> I thought about the following: >> >> UC_UNDEF >> UC_DISABLE >> UC_ENABLE >> UC_TEST >> UC_FORCE >> >> but I am not sure it is much better. > > I hated the DONTUSE/USE I listed, and I think DISABLE/ENABLE is much > much better. I do prefer unspecified over undef, though.
Ok, then it will be:
UC_UNSPECIFIED
UC_DISABLE
UC_ENABLE
UC_TEST
UC_FORCEThanks, Christian.