Re: [PATCH 2/8] update-index: use enum for untracked cache options
- From
Christian Couder <christian.couder@gmail.com>
- Date
- Dec 10, 2015, 10:37 UTC
- Message-ID
- <CAP8UFD3+gsHZuaBweP83or=rEh-LFnz6=ycBCeuhApxp0PzN1A@mail.gmail.com>
- In-Reply-To
- <xmqq1tawlpqw.fsf@gitster.mtv.corp.google.com>
On Tue, Dec 8, 2015 at 8:11 PM, Junio C Hamano <gitster@pobox.com> wrote:
Show 34 quoted lines
> Christian Couder <christian.couder@gmail.com> writes:
>
>> Signed-off-by: Christian Couder <chriscool@tuxfamily.org>
>> ---
>> builtin/update-index.c | 18 +++++++++++++-----
>> 1 file changed, 13 insertions(+), 5 deletions(-)
>>
>> diff --git a/builtin/update-index.c b/builtin/update-index.c
>> index 6f6b289..246b3d3 100644
>> --- a/builtin/update-index.c
>> +++ b/builtin/update-index.c
>> @@ -35,6 +35,14 @@ static int mark_skip_worktree_only;
>> #define UNMARK_FLAG 2
>> static struct strbuf mtime_dir = STRBUF_INIT;
>>
>> +/* Untracked cache mode */
>> +enum uc_mode {
>> + UNDEF_UC = -1,
>> + NO_UC = 0,
>> + UC,
>> + FORCE_UC
>> +};
>> +
>
> With these, the code is much easier to read than with the mystery
> constants, but did you consider making UC_ a common prefix for
> further ease-of-reading? E.g.
>
> UC_UNSPECIFIED
> UC_DONTUSE
> UC_USE
> UC_FORCE
>
> or something?Ok, I will use what you suggest.
Thanks, Christian.