Re: [PATCH 2/8] update-index: use enum for untracked cache options
On Thu, Dec 10, 2015 at 7:46 PM, Junio C Hamano <gitster@pobox.com> wrote:
Show 27 quoted lines
> Christian Couder <christian.couder@gmail.com> writes:
>
>>>> +/* Untracked cache mode */
>>>> +enum uc_mode {
>>>> + UNDEF_UC = -1,
>>>> + NO_UC = 0,
>>>> + UC,
>>>> + FORCE_UC
>>>> +};
>>>> +
>>>
>>> With these, the code is much easier to read than with the mystery
>>> constants, but did you consider making UC_ a common prefix for
>>> further ease-of-reading? E.g.
>>>
>>> UC_UNSPECIFIED
>>> UC_DONTUSE
>>> UC_USE
>>> UC_FORCE
>>>
>>> or something?
>>
>> Ok, I will use what you suggest.
>
> As you know I am bad at bikeshedding; the only suggestion in the
> above is to have common UC_ prefix ;-) Don't take what follow UC_
> as my suggestion.I am bad at finding names too, so I think what you wrote is pretty good.
I thought about the following:
UC_UNDEF
UC_DISABLE
UC_ENABLE
UC_TEST
UC_FORCEbut I am not sure it is much better.