From: Christian Couder Date: Sat, 12 Dec 2015 09:25:37 GMT Subject: Re: [PATCH 2/8] update-index: use enum for untracked cache options Message-ID: In-Reply-To: On Fri, Dec 11, 2015 at 6:44 PM, Junio C Hamano wrote: > Christian Couder writes: > >>> As you know I am bad at bikeshedding; the only suggestion in the >>> above is to have common UC_ prefix ;-) Don't take what follow UC_ >>> as my suggestion. >> >> I am bad at finding names too, so I think what you wrote is pretty good. >> >> I thought about the following: >> >> UC_UNDEF >> UC_DISABLE >> UC_ENABLE >> UC_TEST >> UC_FORCE >> >> but I am not sure it is much better. > > I hated the DONTUSE/USE I listed, and I think DISABLE/ENABLE is much > much better. I do prefer unspecified over undef, though. Ok, then it will be: UC_UNSPECIFIED UC_DISABLE UC_ENABLE UC_TEST UC_FORCE Thanks, Christian.