Re: [PATCH 2/8] update-index: use enum for untracked cache options
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 10, 2015, 18:46 UTC
- Message-ID
- <xmqqh9jqi1ky.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <CAP8UFD3+gsHZuaBweP83or=rEh-LFnz6=ycBCeuhApxp0PzN1A@mail.gmail.com>
Christian Couder <christian.couder@gmail.com> writes:
Show 21 quoted lines
>>> +/* Untracked cache mode */
>>> +enum uc_mode {
>>> + UNDEF_UC = -1,
>>> + NO_UC = 0,
>>> + UC,
>>> + FORCE_UC
>>> +};
>>> +
>>
>> With these, the code is much easier to read than with the mystery
>> constants, but did you consider making UC_ a common prefix for
>> further ease-of-reading? E.g.
>>
>> UC_UNSPECIFIED
>> UC_DONTUSE
>> UC_USE
>> UC_FORCE
>>
>> or something?
>
> Ok, I will use what you suggest.As you know I am bad at bikeshedding; the only suggestion in the above is to have common UC_ prefix ;-) Don't take what follow UC_ as my suggestion.
Thanks.