Re: [PATCH v3 1/5] promisor-remote: refactor to get rid of 'struct strvec'
Christian Couder <christian.couder@gmail.com> writes:
[snip]
Show 11 quoted lines
>
> /*
> - * Find first index of 'nicks' where there is 'nick'. 'nick' is
> - * compared case sensitively to the strings in 'nicks'. If not found
> - * 'nicks->nr' is returned.
> + * Find first element of 'p' where the 'name' member is 'nick'. 'nick'
> + * is compared case sensitively to the strings in 'p'. If not found
> + * NULL is returned.
> */
> -static size_t remote_nick_find(struct strvec *nicks, const char *nick)
> +static struct promisor_info *remote_nick_find(struct promisor_info *p, const char *nick)
Nit: while we're here wouldn't be nicer to rename this to
`promiser_info_list_find_name` or similar?
[snip]