git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/4] promisor-remote: refactor to get rid of 'struct strvec'

From
Christian Couder <christian.couder@gmail.com>
Date
Apr 29, 2025, 15:12 UTC
Message-ID
<CAP8UFD3n09rzS6AMwAP6C=aADW+86r98onL8pci_N_OEF+FPDQ@mail.gmail.com>
In-Reply-To
<aAdrzlUX61TK1x8_@pks.im>
On Tue, Apr 22, 2025 at 12:13 PM Patrick Steinhardt <ps@pks.im> wrote:
>
> On Mon, Apr 14, 2025 at 06:03:41PM +0200, Christian Couder wrote:
Show 17 quoted lines
> > +/*
> > + * Linked list for promisor remotes.
> > + *
> > + * 'fields' should not be sorted, as we will rely on the order we put
> > + * things into it. So, for example, 'string_list_append()' should be
> > + * used instead of 'string_list_insert()'.
> > + */
> > +struct promisor_info {
> > +     struct promisor_info *next;
> > +     struct string_list fields;
> > +};
> > +
> > +static void free_info_list(struct promisor_info *p)
>
> Nit: nowadays we would call this something like
> `promisor_info_list_free()`, with the name of the subsystem coming
> first.
Fine, I have changed it to `promisor_info_list_free()` in the next version.
Show 60 quoted lines
> >  char *promisor_remote_info(struct repository *repo)
> >  {
> >       struct strbuf sb = STRBUF_INIT;
> >       int advertise_promisors = 0;
> > -     struct strvec names = STRVEC_INIT;
> > -     struct strvec urls = STRVEC_INIT;
> > +     struct promisor_info *info_list;
> > +     struct promisor_info *r, *p;
> >
> >       git_config_get_bool("promisor.advertise", &advertise_promisors);
> >
> >       if (!advertise_promisors)
> >               return NULL;
> >
> > -     promisor_info_vecs(repo, &names, &urls);
> > +     info_list = promisor_info_list(repo);
> >
> > -     if (!names.nr)
> > +     if (!info_list)
> >               return NULL;
> >
> > -     for (size_t i = 0; i < names.nr; i++) {
> > -             if (i)
> > +     for (p = NULL, r = info_list; r; p = r, r = r->next) {
> > +             struct string_list_item *item;
> > +             int first = 1;
> > +
> > +             if (r != info_list)
> >                       strbuf_addch(&sb, ';');
> > -             strbuf_addstr(&sb, "name=");
> > -             strbuf_addstr_urlencode(&sb, names.v[i], allow_unsanitized);
> > -             strbuf_addstr(&sb, ",url=");
> > -             strbuf_addstr_urlencode(&sb, urls.v[i], allow_unsanitized);
> > +
> > +             for_each_string_list_item(item, &r->fields) {
> > +                     if (first)
> > +                             first = 0;
> > +                     else
> > +                             strbuf_addch(&sb, ',');
> > +                     strbuf_addf(&sb, "%s=", item->string);
> > +                     strbuf_addstr_urlencode(&sb, (char *)item->util, allow_unsanitized);
> > +             }
> >       }
> >
> > -     strvec_clear(&names);
> > -     strvec_clear(&urls);
> > +     free_info_list(p);
>
> I don't quite follow the usage pattern of `info_list` here. My
> expectation is that we'd:
>
>   1. Acquire the promisor info list.
>
>   2. Iterate through each of its items.
>
>   3. Free the complete list.
>
> But why do we free `p` here? Shouldn't we free `info_list`? And if we
> did so, can't we drop `p` completely and just iterate through the list
> via `r`?
Yeah, it's a bug that is fixed in the next version.
Show 23 quoted lines
> >       return strbuf_detach(&sb, NULL);
> >  }
> >
> >  /*
> > - * Find first index of 'nicks' where there is 'nick'. 'nick' is
> > - * compared case sensitively to the strings in 'nicks'. If not found
> > - * 'nicks->nr' is returned.
> > + * Find first element of 'p' where the 'name' field is 'nick'. 'nick'
> > + * is compared case sensitively to the strings in 'p'. If not found
> > + * NULL is returned.
> >   */
> > -static size_t remote_nick_find(struct strvec *nicks, const char *nick)
> > +static struct promisor_info *remote_nick_find(struct promisor_info *p, const char *nick)
> >  {
> > -     for (size_t i = 0; i < nicks->nr; i++)
> > -             if (!strcmp(nicks->v[i], nick))
> > -                     return i;
> > -     return nicks->nr;
> > +     for (; p; p = p->next) {
> > +             assert(!strcmp(p->fields.items[0].string, "name"));
>
> Why do we add this assert now? And if we want to keep it, shouldn't it
> rather be `BUG()`?
Yeah, it's now BUG() in the next version.
Show 11 quoted lines
> > @@ -414,11 +461,16 @@ static int should_accept_remote(enum accept_promisor accept,
> >               return 0;
> >       }
> >
> > -     if (!strcmp(urls->v[i], remote_url))
> > +     if (strcmp(p->fields.items[1].string, "url"))
> > +             BUG("Bad info_list for remote '%s'", remote_name);
>
> It feels somewhat fragile to assume hardcoded locations of each of the
> keys in `fields.items`. Would it be preferable to instead have a
> function that looks up the index by key?

On the other hand we always require a 'name' and a 'url' fields, so putting them first can simplify and speed things up.

If the checks look too ugly maybe they can be abstracted out in functions dedicated to get the name or the url?

Previous: Patrick SteinhardtNext: Christian Couder
Message 5 of 107 in “Make the "promisor-remote" capability support extra fields”
  1. 0/4 Make the "promisor-remote" capability support extra fieldsChristian Couder, Apr 14, 2025
  2. 1/4 config: move is_config_key_char() to "config.h"Christian Couder, Apr 14, 2025
  3. 2/4 promisor-remote: refactor to get rid of 'struct strvec'Christian Couder, Apr 14, 2025
  4. Patrick SteinhardtApr 22, 2025
  5. Christian CouderApr 29, 2025
  6. 3/4 promisor-remote: allow a server to advertise extra fieldsChristian Couder, Apr 14, 2025
  7. Junio C HamanoApr 14, 2025
  8. Patrick SteinhardtApr 22, 2025
  9. Christian CouderApr 29, 2025
  10. Christian CouderApr 29, 2025
  11. 4/4 promisor-remote: allow a client to check extra fieldsChristian Couder, Apr 14, 2025
  12. 0/3 Make the "promisor-remote" capability support more fieldsChristian Couder, Apr 29, 2025
  13. 1/3 promisor-remote: refactor to get rid of 'struct strvec'Christian Couder, Apr 29, 2025
  14. Patrick SteinhardtMay 7, 2025
  15. Christian CouderMay 19, 2025
  16. Karthik NayakMay 7, 2025
  17. Christian CouderMay 19, 2025
  18. 2/3 promisor-remote: allow a server to advertise more fieldsChristian Couder, Apr 29, 2025
  19. Patrick SteinhardtMay 7, 2025
  20. Christian CouderMay 19, 2025
  21. Patrick SteinhardtMay 27, 2025
  22. Junio C HamanoMay 27, 2025
  23. Christian CouderJun 11, 2025
  24. Karthik NayakMay 7, 2025
  25. Christian CouderMay 19, 2025
  26. 3/3 promisor-remote: allow a client to check fieldsChristian Couder, Apr 29, 2025
  27. Patrick SteinhardtMay 7, 2025
  28. Christian CouderMay 19, 2025
  29. Christian CouderMay 2, 2025
  30. 0/5 Make the "promisor-remote" capability support more fieldsChristian Couder, May 19, 2025
  31. 1/5 promisor-remote: refactor to get rid of 'struct strvec'Christian Couder, May 19, 2025
  32. Karthik NayakMay 20, 2025
  33. Christian CouderMay 20, 2025
  34. Junio C HamanoMay 20, 2025
  35. Christian CouderMay 21, 2025
  36. Junio C HamanoMay 21, 2025
  37. Christian CouderJun 11, 2025
  38. 2/5 promisor-remote: allow a server to advertise more fieldsChristian Couder, May 19, 2025
  39. Justin ToblerMay 21, 2025
  40. Christian CouderJun 11, 2025
  41. Patrick SteinhardtMay 27, 2025
  42. Christian CouderJun 11, 2025
  43. 3/5 promisor-remote: refactor how we parse advertised fieldsChristian Couder, May 19, 2025
  44. 4/5 promisor-remote: allow a client to check fieldsChristian Couder, May 19, 2025
  45. 5/5 promisor-remote: use string constants for 'name' and 'url' tooChristian Couder, May 19, 2025
  46. 0/5 Make the "promisor-remote" capability support more fieldsChristian Couder, Jun 11, 2025
  47. 1/5 promisor-remote: refactor to get rid of 'struct strvec'Christian Couder, Jun 11, 2025
  48. Karthik NayakJun 19, 2025
  49. Christian CouderJun 25, 2025
  50. Justin ToblerJun 23, 2025
  51. Christian CouderJun 25, 2025
  52. 2/5 promisor-remote: allow a server to advertise more fieldsChristian Couder, Jun 11, 2025
  53. Karthik NayakJun 19, 2025
  54. Christian CouderJun 25, 2025
  55. Justin ToblerJun 23, 2025
  56. Christian CouderJun 25, 2025
  57. 3/5 promisor-remote: refactor how we parse advertised fieldsChristian Couder, Jun 11, 2025
  58. 4/5 promisor-remote: allow a client to check fieldsChristian Couder, Jun 11, 2025
  59. 5/5 promisor-remote: use string constants for 'name' and 'url' tooChristian Couder, Jun 11, 2025
  60. Karthik NayakJun 19, 2025
  61. 0/5 Make the "promisor-remote" capability support more fieldsChristian Couder, Jun 25, 2025
  62. 1/5 promisor-remote: refactor to get rid of 'struct strvec'Christian Couder, Jun 25, 2025
  63. Junio C HamanoJun 25, 2025
  64. Christian CouderJul 21, 2025
  65. 3/5 promisor-remote: refactor how we parse advertised fieldsChristian Couder, Jun 25, 2025
  66. 2/5 promisor-remote: allow a server to advertise more fieldsChristian Couder, Jun 25, 2025
  67. Junio C HamanoJun 25, 2025
  68. Christian CouderJul 21, 2025
  69. Junio C HamanoJul 21, 2025
  70. Christian CouderJul 31, 2025
  71. Jean-Noël AvilaJun 27, 2025
  72. Christian CouderJul 21, 2025
  73. 4/5 promisor-remote: allow a client to check fieldsChristian Couder, Jun 25, 2025
  74. 5/5 promisor-remote: use string constants for 'name' and 'url' tooChristian Couder, Jun 25, 2025
  75. Junio C HamanoJul 7, 2025
  76. Christian CouderJul 8, 2025
  77. 0/5 Make the "promisor-remote" capability support more fieldsChristian Couder, Jul 21, 2025
  78. 1/5 promisor-remote: refactor to get rid of 'struct strvec'Christian Couder, Jul 21, 2025
  79. 2/5 promisor-remote: allow a server to advertise more fieldsChristian Couder, Jul 21, 2025
  80. 3/5 promisor-remote: refactor how we parse advertised fieldsChristian Couder, Jul 21, 2025
  81. Junio C HamanoJul 21, 2025
  82. Christian CouderJul 31, 2025
  83. 4/5 promisor-remote: allow a client to check fieldsChristian Couder, Jul 21, 2025
  84. Junio C HamanoJul 21, 2025
  85. Christian CouderJul 31, 2025
  86. 5/5 promisor-remote: use string constants for 'name' and 'url' tooChristian Couder, Jul 21, 2025
  87. Junio C HamanoJul 21, 2025
  88. 0/5 Make the "promisor-remote" capability support more fieldsChristian Couder, Jul 31, 2025
  89. 1/5 promisor-remote: refactor to get rid of 'struct strvec'Christian Couder, Jul 31, 2025
  90. 2/5 promisor-remote: allow a server to advertise more fieldsChristian Couder, Jul 31, 2025
  91. 3/5 promisor-remote: refactor how we parse advertised fieldsChristian Couder, Jul 31, 2025
  92. Junio C HamanoJul 31, 2025
  93. Christian CouderSep 8, 2025
  94. 4/5 promisor-remote: allow a client to check fieldsChristian Couder, Jul 31, 2025
  95. 5/5 promisor-remote: use string constants for 'name' and 'url' tooChristian Couder, Jul 31, 2025
  96. Junio C HamanoJul 31, 2025
  97. Junio C HamanoAug 28, 2025
  98. Christian CouderSep 8, 2025
  99. 0/7 Make the "promisor-remote" capability support more fieldsChristian Couder, Sep 8, 2025
  100. 1/7 promisor-remote: refactor to get rid of 'struct strvec'Christian Couder, Sep 8, 2025
  101. 2/7 promisor-remote: allow a server to advertise more fieldsChristian Couder, Sep 8, 2025
  102. 3/7 promisor-remote: use string constants for 'name' and 'url' tooChristian Couder, Sep 8, 2025
  103. 4/7 promisor-remote: refactor how we parse advertised fieldsChristian Couder, Sep 8, 2025
  104. 5/7 promisor-remote: use string_list_split() in filter_promisor_remote()Christian Couder, Sep 8, 2025
  105. 6/7 promisor-remote: allow a client to check fieldsChristian Couder, Sep 8, 2025
  106. 7/7 promisor-remote: use string_list_split() in mark_remotes_as_accepted()Christian Couder, Sep 8, 2025
  107. Junio C HamanoSep 8, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.