From: Karthik Nayak Date: Tue, 20 May 2025 09:37:43 GMT Subject: Re: [PATCH v3 1/5] promisor-remote: refactor to get rid of 'struct strvec' Message-ID: In-Reply-To: <20250519141259.3061550-2-christian.couder@gmail.com> Christian Couder writes: [snip] > > /* > - * Find first index of 'nicks' where there is 'nick'. 'nick' is > - * compared case sensitively to the strings in 'nicks'. If not found > - * 'nicks->nr' is returned. > + * Find first element of 'p' where the 'name' member is 'nick'. 'nick' > + * is compared case sensitively to the strings in 'p'. If not found > + * NULL is returned. > */ > -static size_t remote_nick_find(struct strvec *nicks, const char *nick) > +static struct promisor_info *remote_nick_find(struct promisor_info *p, const char *nick) Nit: while we're here wouldn't be nicer to rename this to `promiser_info_list_find_name` or similar? [snip]