Re: [PATCH 5/6] reftable: drop unused parameter from reader_seek_linear()
- From
Han-Wen Nienhuys <hanwen@google.com>
- Date
- Aug 22, 2022, 07:46 UTC
- Message-ID
- <CAFQ2z_PHq6wFbZwiRnpS4NDmUu3nbRyhq=302Pys31mPa8VTew@mail.gmail.com>
- In-Reply-To
- <5f10be7e-424a-ed3b-bb77-75f1e026b2ae@github.com>
On Fri, Aug 19, 2022 at 9:06 PM Derrick Stolee <derrickstolee@github.com> wrote:
Show 10 quoted lines
> > On 8/19/2022 4:54 AM, Jeff King wrote: > > The reader code passes around a "struct reftable_reader" context > > variable. But the seek function doesn't need it; the table iterator we > > already get is sufficient. > > If we wanted to make it seem more like it was a method of something, > it now looks to operate on the table_iter, so the method name could > change to something like "table_seek_linear()" which might satisfy > both goals.
+1. Name should be table_iter_seek_linear to stick with naming conventions, and should move to the top of the file next to other table_iter methods.
-- Han-Wen Nienhuys - Google Munich I work 80%. Don't expect answers from me on Fridays. -- Google Germany GmbH, Erika-Mann-Strasse 33, 80636 Munich Registergericht und -nummer: Hamburg, HRB 86891 Sitz der Gesellschaft: Hamburg Geschäftsführer: Paul Manicle, Liana Sebastian