Re: [PATCH] diff: prefer indent heuristic over compaction heuristic
- From
Jacob Keller <jacob.keller@gmail.com>
- Date
- Dec 23, 2016, 22:23 UTC
- Message-ID
- <CA+P7+xrMFnW8NCySpMuWWnXBE30RwmOgr-0Xgjaa5i8eDPGGUw@mail.gmail.com>
- In-Reply-To
- <20161223222145.vkf6mjvs5t7ag3od@sigill.intra.peff.net>
On Fri, Dec 23, 2016 at 2:21 PM, Jeff King <peff@peff.net> wrote:
Show 16 quoted lines
> On Fri, Dec 23, 2016 at 01:17:03PM -0800, Junio C Hamano wrote: > >> Junio C Hamano <gitster@pobox.com> writes: >> >> > I guess both you and Michael are in favor of just removing compaction >> > variant without any renames, so let me prepare a reroll and queue >> > that instead. We can flip the default perhaps one release later. >> >> -- >8 -- >> Subject: [PATCH] diff: retire "compaction" heuristics > > Looks good to me from a cursory read. > > Thanks. > > -Peff
Same. This is more obviously correct since we didn't have to change a bunch of references to INDENT_HEURISTIC. I agree that the name does not make sense now, but if our goal is to make it default with a disable option, I think that we shouldn't worry too much about the naming.
Thanks, Jake