From: Jacob Keller Date: Fri, 23 Dec 2016 22:23:24 GMT Subject: Re: [PATCH] diff: prefer indent heuristic over compaction heuristic Message-ID: In-Reply-To: <20161223222145.vkf6mjvs5t7ag3od@sigill.intra.peff.net> On Fri, Dec 23, 2016 at 2:21 PM, Jeff King wrote: > On Fri, Dec 23, 2016 at 01:17:03PM -0800, Junio C Hamano wrote: > >> Junio C Hamano writes: >> >> > I guess both you and Michael are in favor of just removing compaction >> > variant without any renames, so let me prepare a reroll and queue >> > that instead. We can flip the default perhaps one release later. >> >> -- >8 -- >> Subject: [PATCH] diff: retire "compaction" heuristics > > Looks good to me from a cursory read. > > Thanks. > > -Peff Same. This is more obviously correct since we didn't have to change a bunch of references to INDENT_HEURISTIC. I agree that the name does not make sense now, but if our goal is to make it default with a disable option, I think that we shouldn't worry too much about the naming. Thanks, Jake