Re: [PATCH] commit: Add commit_list prefix to reduce_heads function.
- From
Thiago Farina <tfransosi@gmail.com>
- Date
- Dec 5, 2010, 12:23 UTC
- Message-ID
- <AANLkTikxibh4QkxzokhBYQ+dMS3W6PkDaDLuqm5qN+6v@mail.gmail.com>
- In-Reply-To
- <7vsjycx05o.fsf@alter.siamese.dyndns.org>
On Sun, Dec 5, 2010 at 3:24 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 6 quoted lines
> Thiago Farina <tfransosi@gmail.com> writes: > >> Signed-off-by: Thiago Farina <tfransosi@gmail.com> > > I really do not like this. >
I don't feel very strong about it. And as I learned from Jonathan, I don't care if you will take or not. I think my intention was good, but I can't please everybody
I was just trying to put commit_list in a better shape and resemble it in a more explicit API.
Show 8 quoted lines
> The use of type "struct commit_list" to hold the set of parent commits is > incidental; if we had "struct commit_set", we would have written a > function with the same purpose, and named it the same "reduce_HEADS". > > Adding commit_list to the name makes the code harder to read (and type) > with little added benefit. "LIST"-ness is not the important part. > > If a function takes a commit_list, named "reduce_HEADS",
What? reduce_HEADS ? HEADS with CAPSLOCK?