Re: [PATCH] commit: Add commit_list prefix to reduce_heads function.
- From
Thiago Farina <tfransosi@gmail.com>
- Date
- Dec 5, 2010, 17:32 UTC
- Message-ID
- <AANLkTinjJpGW2OiXM3edWYaNhS+w4qNLrvg-0aBwsL=x@mail.gmail.com>
- In-Reply-To
- <AANLkTikL4BWtzNgx1+MBYxRRdfL=Gu71KPjaiKXprvnb@mail.gmail.com>
On Sun, Dec 5, 2010 at 3:29 PM, Thiago Farina <tfransosi@gmail.com> wrote:
Show 12 quoted lines
> On Sun, Dec 5, 2010 at 3:09 PM, Jonathan Nieder <jrnieder@gmail.com> wrote: >> - "At my office there is a style guide indicating that each function >> should live in a module with some other functions and be named to >> indicate so (like perf, with its sched__* etc functions). The idea >> is that code with a simple high-level structure tends to be easier >> to understand and we need to understand the code we use. Can we >> start changing the code to fit this style guide, so there is less >> resistance to using it at my office?" >> > For me that is a good reason and I think it matches with what I had in > mind but didn't write. Thanks for pointing it out. >
Also I thought that as Junio already picked up the other patch. It's was a hint that the other functions that has "struct commit_list *l" as its parameters could be renamed as well. But I was wrong it seems.