From: Thiago Farina Date: Sun, 05 Dec 2010 12:23:14 GMT Subject: Re: [PATCH] commit: Add commit_list prefix to reduce_heads function. Message-ID: In-Reply-To: <7vsjycx05o.fsf@alter.siamese.dyndns.org> On Sun, Dec 5, 2010 at 3:24 AM, Junio C Hamano wrote: > Thiago Farina writes: > >> Signed-off-by: Thiago Farina > > I really do not like this. > I don't feel very strong about it. And as I learned from Jonathan, I don't care if you will take or not. I think my intention was good, but I can't please everybody I was just trying to put commit_list in a better shape and resemble it in a more explicit API. > The use of type "struct commit_list" to hold the set of parent commits is > incidental; if we had "struct commit_set", we would have written a > function with the same purpose, and named it the same "reduce_HEADS". > > Adding commit_list to the name makes the code harder to read (and type) > with little added benefit.  "LIST"-ness is not the important part. > > If a function takes a commit_list, named "reduce_HEADS", What? reduce_HEADS ? HEADS with CAPSLOCK?