Re: [PATCH] commit: Add commit_list prefix to reduce_heads function.
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 6, 2010, 04:01 UTC
- Message-ID
- <7v7hfntuqt.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <AANLkTi=QK=N+_iGR9-47JKFs_SDKujJ8c4mtnnM0yo94@mail.gmail.com>
Thiago Farina <tfransosi@gmail.com> writes:
Show 11 quoted lines
>> "insert-by-date" does not say _why_ you want things to be inserted by date >> (neither "sort-by-date"). They are pretty generic looking names for any >> function that deal with a list of elements that record date. It makes >> sense to anticipate there will be many other such functions that deal with >> different kinds of lists that hold date-recording things, and naming one >> of them "this deals with list of COMMITS" by saying "commit_list_foo" >> makes quite a lot of sense, as "insert-by-date" does not give sufficient >> information to the reader. >> > That makes sense to me. And clarified why the complain at all. And you > are right.
Actually I think s/insert_by_date/commit_list_insert_by_date/ is a mistake. Something like insert-commit-by-date would be more appropriate. Similarly for s/sort_by_date/commit_list_sort_by_date/