Re: [PATCH v2 4/7] config: add --fixed-value option, un-implemented
- From
Derrick Stolee <stolee@gmail.com>
- Date
- Nov 25, 2020, 14:08 UTC
- Message-ID
- <91af356f-d0a0-1149-15dc-32da803ac6d9@gmail.com>
- In-Reply-To
- <xmqqy2irlmq5.fsf@gitster.c.googlers.com>
On 11/23/2020 5:41 PM, Junio C Hamano wrote:
Show 11 quoted lines
> Emily Shaffer <emilyshaffer@google.com> writes:
>
>>> OPT_BIT('l', "list", &actions, N_("list all"), ACTION_LIST),
>>> + OPT_BOOL(0, "fixed-value", &fixed_value, N_("use string equality when matching values")),
>> I'm not sure how to feel about this phrasing. I wonder if it would be
>> clearer to say something like 'treat 'value_regex' as a literal string
>> instead'? Hmmm.
>
> Update the document and help text with s/value_regex/value_pattern/
> and say "use value_pattern as a fixed string, not an extended regexp",
> perhaps?If I go about changing all documentation and error messages to say "value_pattern" instead of "value_regex", should I also update the uses in the *.po translation files? Or, should I leave them unmodified to trigger manual intervention by the translators?
Thanks, -Stolee