Re: [PATCH v2 4/7] config: add --fixed-value option, un-implemented
- From
Derrick Stolee <stolee@gmail.com>
- Date
- Nov 25, 2020, 17:22 UTC
- Message-ID
- <6b2b5af7-e73e-7584-6515-0e1d65c5e6d1@gmail.com>
- In-Reply-To
- <91af356f-d0a0-1149-15dc-32da803ac6d9@gmail.com>
On 11/25/2020 9:08 AM, Derrick Stolee wrote:
Show 17 quoted lines
> On 11/23/2020 5:41 PM, Junio C Hamano wrote:
>> Emily Shaffer <emilyshaffer@google.com> writes:
>>
>>>> OPT_BIT('l', "list", &actions, N_("list all"), ACTION_LIST),
>>>> + OPT_BOOL(0, "fixed-value", &fixed_value, N_("use string equality when matching values")),
>>> I'm not sure how to feel about this phrasing. I wonder if it would be
>>> clearer to say something like 'treat 'value_regex' as a literal string
>>> instead'? Hmmm.
>>
>> Update the document and help text with s/value_regex/value_pattern/
>> and say "use value_pattern as a fixed string, not an extended regexp",
>> perhaps?
>
> If I go about changing all documentation and error messages to say
> "value_pattern" instead of "value_regex", should I also update the uses
> in the *.po translation files? Or, should I leave them unmodified to
> trigger manual intervention by the translators?I have discovered that changing these causes conflicts with automated line number updates. I'll leave these unchanged with a note for translators.
Thanks, -Stolee