Re: [PATCH v3 03/30] subtree: t7900: use test-lib.sh's test_count
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Apr 30, 2021, 09:45 UTC
- Message-ID
- <87wnskxfwo.fsf@evledraar.gmail.com>
- In-Reply-To
- <20210427211748.2607474-4-lukeshu@lukeshu.com>
On Tue, Apr 27 2021, Luke Shumaker wrote:
Show 5 quoted lines
> From: Luke Shumaker <lukeshu@datawire.io> > > Use test-lib.sh's `test_count`, instead instead of having > t7900-subtree.sh do its own book-keeping with `subtree_test_count` that > has to be explicitly incremented by calling `next_test`.
This just retains an existing pattern and all that, but I think this pattern of testing makes for hard to read & maintain tests. It looks like all of these could just be:
test_when_finished "rm -rf repo" &&
git init repo &&
[...]I.e. the only thing that's being done here is to piggy-back on the test count to create a unique repo.